CentOS 6.5 安装 Python3

转载 2015年07月08日 19:34:28

通常在CentOS上已经安装了Python,但是Python3是需要自己安装的。找了下资料,其实先安装gcc等编译环境,然后下载Python3源码编译后再安装,安装好后在进行一定的设定。具体情况如下:

安装环境
yum install gcc
yum install zlib-devel
yum install make
下载python版本
wget http://www.python.org/ftp/python/3.4.0/Python-3.4.0.tgz
解压缩、编译和安装
tar -zxvf Python-3.4.0.tgz
cd Python-3.4.0
./configure –prefix=/opt/python3
make all
make install
清除之前编译的可执行文件及配置文件。
make clean
清除所有生成的文件
make distclean
查看安装的新版本信息
/opt/python3/bin/python3 -V
Python 3.4.0
由此看出编译安装的新版本python生效了
做个软连接到当前用户的bin目录
ln -s /opt/python3/bin/python3 ~/bin/python3
升级安装好新版本python以后,默认依然是python2.6
将文件头部的#!/usr/bin/python修改为 #!/opt/python3/bin/python3 即可。

转载注明出处:http://my.oschina.net/jianweizhang/blog/195166

相关文章推荐

CentOS 6.5 安装python2.7 & scrapy 框架

  • 2016年07月14日 16:21
  • 13.84MB
  • 下载

Install Python 2/3 on CentOS 6.5 Server

参考: http://www.shayanderson.com/linux/install-python-3-on-centos-6-server.htm 另也可获取源: wget http://...
  • textboy
  • textboy
  • 2015年09月06日 16:05
  • 725

Centos6.5 安装zabbix3

1.安装PHP Zabbix 3.0对PHP的要求最低为5.4,而CentOS6默认为5.3.3,完全不满足要求,故需要利用第三方源,将PHP升级到5.4以上,注意,不支持PHP7 rpm -iv...

CentOS 6.5升级Python和安装IPython

以前用CentOS 5.8的时候,写过一篇《升级CentOS的Python》。后来换成了CentOS 6.5,系统自带的Python版本是2.6.6,就懒得折腾。最近安装IPython,才发现IPyt...

centos 6.5 安装MySQL-python模块

如果你服务器环境允许yum,安装MySQL-python模块就很简单了 [python] view plain copy   yum instal...

centos6.5安装python2.7.12

本文引用了两篇播客: http://www.cnblogs.com/dudu/p/4294238.html  http://ypf3027.iteye.com/blog/2018553 在L...

Centos6.5 安装各python版本及pip

Centos6.5 默认的版本python版本是2.6,很多情况下我们需要使用python2.7和python3.4。还要安装对应的pip来安装对应的模块到site-packages下面~~~~有点蛋...
  • karchar
  • karchar
  • 2016年09月21日 00:44
  • 293

在CentOS 6.3/6.5 64bit上为python 2.7.10安装pycurl模块

公司线上都是使用CentOS 6.3 64bit版本,我家里装的是CentOS 6.6,它们默认的python版本是2.6.6.而我编写的几个python脚本是在Ubuntu 14.04 64bit上...
  • tao_627
  • tao_627
  • 2015年07月18日 12:43
  • 1258

程序员的机器学习入门笔记(二):Python常用库的介绍,及安装(Centos 6.5)

在Python的世界中为数据挖掘产生了很多实用的库,本文主要列出一些常见库的说明,安装,以及使用的小例子,文中的安装以及演示环境都是基于Centos 6.5 的Desktop Mini版进行演示 ...

Centos6.5 安装基于Python3.6 的TensorFlow

TensorFlow安装过程
  • guotch
  • guotch
  • 2017年06月10日 14:01
  • 831
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:CentOS 6.5 安装 Python3
举报原因:
原因补充:

(最多只允许输入30个字)