poj_3278_Catch That Cow广搜

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 68714 Accepted: 21637

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

/*****************************************

第一次做广搜和深搜的题的时候都是一次AC,真是太高兴了(虽然是水题)

调程序的时候发现忘了写  q.pop();  真是。。。

*****************************************/

<span style="font-size:14px;">#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
using namespace std;

int N,K;
int floorn[100001];
int visit[100001];
queue <int> q;

int main()
{
    cin >> N >> K;                              //输入及初始化
    q.push(N);
    memset(visit, 0, sizeof(visit));
    memset(floorn, 0, sizeof(floorn));
    while(!q.empty())                           //每次取队列头节点,分层并且标记
    {
        int a = q.front();
        visit[a] = 1;
        if (a == K)                             //搜索结束条件
        {
            printf("%d\n",floorn[a]);
            break;
        }
        if ((a-1 >= 0) && (!visit[a-1]))
        {
            q.push(a-1);
            floorn[a-1] = floorn[a] + 1;
            visit[a-1] = 1; 
        }
        if ((a+1 <= 100000) && (!visit[a+1]))
        {
            q.push(a+1);
            floorn[a+1] = floorn[a] + 1; 
            visit[a+1] = 1;
        }
        if ((2*a <= 100000) && (!visit[2*a]))
        {
            q.push(2*a);
            floorn[2*a] = floorn[a] + 1; 
            visit[2*a] = 1;
        }
        q.pop();                                //每次头节点分析完后一定要踢掉,感觉就像深搜的回溯
    }
    return 0;
}</span>

一会换一种解法,再来更新

/××××××××××××××××××××××××××

好吧这次做得太慢了,因为找错找了好久没找到,

最后发现是visit[100000];没有包含坐标为100000的值。。。

失误失误。。。以后绝不会再犯这样的错哭

××××××××××××××××××××××××××/

<span style="font-size:14px;">#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
using namespace std;

int N,K;
int visit[100010];

struct abc
{
    int x;
    int floorn;
    abc(int aa,int bb):x(aa),floorn(bb){}
};
queue <abc> q;

int main()
{
    cin >> N >> K;
    q.push(abc(N,0));
    memset(visit,0,sizeof(visit));
    visit[N] = 1;
    while (!q.empty())
    {
        abc a = q.front();
        if (a.x == K)
        {
            printf("%d\n",a.floorn);
            break;
        }
        if ((a.x-1 >= 0) && (!visit[a.x-1]))
        {
            q.push(abc(a.x-1,a.floorn+1));
            visit[a.x-1] = 1;
        }
        if ((a.x+1 <= 100000) && (!visit[a.x+1]))
        {
            q.push(abc(a.x+1,a.floorn+1));
            visit[a.x+1] = 1;
        }
        if ((2*a.x <= 100000) && (!visit[2*a.x]))
        {
            q.push(abc(2*a.x,a.floorn+1));
            visit[2*a.x] = 1;
        }
        q.pop();
    }
    return 0;
}</span>

感谢阅读

感谢讨论

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值