A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 281356 Accepted Submission(s): 54169

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
#define N 1005

int main()
{
    char A[N],B[N],S[N];
    int T, i, j, k, l, flag;

     while(scanf("%d",&T)!=EOF){ // 输入要输入的组数

        for(i=0;i<T;i++){ 

            if(i){ // 除了第一个输出,其它的都先空一行 
                printf("\n");
            }

            scanf("%s%s",&A,&B); // A、B是两个要输入的数对应的字符串 

            k=strlen(A)-1; // k、l分别是A、B数组最后一位的下标 
            l=strlen(B)-1;

            j=0,flag=0; // j是和的下标,flag是要进的数(例如:A、B某一个位和为23,则向前进2)

            while((k+1)&&(l+1)){ // 取位数最小的作为求和部分(如:11+222,取11+22) 

                S[j]=(A[k]-'0')+(B[l]-'0')+flag; // 求A、B之和每一位的数值

                if(S[j]>=10){ // 保证每一位的合理性,如(某一位是7+2,然后他的下一位进2,那么它要向j+1位进1) 
                    S[j]=S[j]-10;
                    flag=1;
                }
                else{
                    flag=0;
                } 

                k--;
                l--;
                j++;
            }

            if(k+1){ // 非共有部分剩A数 
                while(k>=0){
                    S[j]=(A[k]-'0')+flag; // 第一次的flag是之前共有部分最前一位的进位 

                    if(S[j]>=10){ // 确定是否由于共有部分的进位引起全部进位 
                        S[j]=S[j]-10;
                        flag=1;
                    }
                    else{
                        flag=0;
                    } 

                    k--;
                    j++;
                }
            } 

            else if(l+1){ // B数比较大时 
                while(l>=0){
                    S[j]=(B[l]-'0')+flag;

                    if(S[j]>=10){ // 确定进位 
                        S[j]=S[j]-10;
                        flag=1;
                    }
                    else{
                        flag=0;
                    } 

                    l--;
                    j++;
                }
            } 

            if(flag){ // 确定最大那一位是否会再往前进 
                S[j]=flag;
            } 
            else{
                j--;
            } 

            printf("Case %d:\n",i+1);
            printf("%s + %s = ",A,B);
            while(j>-1){
                printf("%d",S[j--]);
            }  
            printf("\n");    
     }
 }
 return 0; 
}

这里写图片描述
这里写图片描述
这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值