Z - A + B Problem II(HDU 1002)

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
题解

题意:

  • 大整数加法

思路:

  • 我用的比较一般的方法,老老实实地从末位相加,进位。(看代码注释)
Code
#include<iostream>
#include<string>
#include<cstring>
#include<stack>
using namespace std;

char a[1005], b[1005];//将两个大整数当作字符串存入数组
stack <char> aa;
stack <char> bb;
stack <int> cc;

int main()
{ 
    int la, lb, n, ret, num;
    cin>>n;
    for (int  i = 1; i <= n; i++)
    {
        cin >> a >> b;
        la = strlen(a);
        lb = strlen(b);
        ret = 0;
        num = 0;
        for (int j = 0; j < la; j++)//压栈,高位存在栈底
            aa.push(a[j]);
        
        for (int j = 0; j < lb; j++)
            bb.push(b[j]);

        while (!aa.empty() && !bb.empty())//两个数从低位逐位相加,ret为进位
        {								//循环结束时,必有一个栈空
            num = aa.top()- '0' + bb.top() - '0';
            cc.push((num + ret) % 10);
            ret = (num + ret) / 10;
            aa.pop();
            bb.pop();
        }
        while (!bb.empty())//将非空的栈里的元素继续处理为数字存入栈cc
        {
            num = bb.top() - '0';
            cc.push((num + ret) % 10);
            ret = (num + ret) / 10;
            bb.pop();
        }
        while (!aa.empty())
        {
            num = aa.top() - '0';
            cc.push((num + ret) % 10);
            ret = (num + ret) / 10;
            aa.pop();
        }
        if(ret != 0)//最后判断进位是否为0
            cc.push(ret);

        printf("Case %d:\n%s + %s = ", i, a, b);
        
        while (!cc.empty())//高位后入栈,先输出        
        {  
            cout<<cc.top();
            cc.pop();     
        } 
        printf("\n");
        if(i != n)
            printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值