A + B Problem II C语言解析(大数相加)

该博客主要讲述了如何在C语言中处理大数相加的问题,由于数值超出常规整型范围,因此采用字符串数组存储并逐位相加的方法。文章提供了样例输入和输出,并提到了杭电ACM竞赛中对于格式要求的严格性。
摘要由CSDN通过智能技术生成

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

求A+B的和,但是A和B非常大,超出了long long的范围,所以只能用字符串数组保存数字并逐位相加。
杭电对格式的要求有点高,交了13次才发现格式的错误,坑!!!

一,两个字符串都从最后一位向前走,将相加结果用数组保存,最后倒序输出
  123
+1123   都从个位(最后)开始相加

或者

二,先将两个字符串逆序,然后从第一位开始相加,用数组保存数据,最后倒序输出
  123   -->    321    
+1123   -->   +3211   从第一位开始相加
#include<stdio.h>
#include<string.h>
int main()
{
   
	int n,len1,len2,k=1,i,j,flag=0,t,m;
	char a[1005],b[1005],sum[1005]={
   0};
	
	scanf("%d",&n);
	while(n--)
	{
   
		memset(sum,0,sizeof(sum));//初始化数组,memset在string函数库里
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		
		scanf("%s%s",&a,&b
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值