UVA Minimal coverage (贪心)

Description

Download as PDF


 Minimal coverage 

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1

Alex Gevak
September 10, 2000 (Revised 2-10-00, Antonio Sanchez)



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    int l;
    int r;
} q[100100];

int cmp(const void *a,const void *b)
{
    struct node *aa,*bb;
    aa = (struct node*)a;
    bb = (struct node*)b;
    return aa->l - bb->l;
}

int main()
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--)
    {
        int m;
        scanf("%d",&m);
        n = 0;
        while(scanf("%d%d",&q[n].l,&q[n].r)!=EOF)
        {
            if(q[n].l == 0 && q[n].r == 0)
            {
                break;
            }
            n++;
        }
        qsort(q,n,sizeof(q[0]),cmp);
        int pmax = 0;
        int pi = 0;
        int ff = 0;
        for(int i=0; i<n; i++)
        {
            if(q[i].l<=0 && q[i].r>pmax)
            {
                ff = 1;
                pmax = q[i].r;
                pi = i;
            }
            else if(q[i].l>0)
            {
                break;
            }
        }
        if(ff == 0)
        {
            printf("0\n");
            continue;
        }
        int left = 0;
        int right = pmax;
        int maxx = 0;
        int a[10010];
        int k = 0;
        int p = 0;
        int h = 0;
        int flag = 0;
        a[p] = pi;
        p++;
        for(int i=0; i<n; i++)
        {
           
            if(q[i].l<=right && q[i].r>maxx)
            {
                if(flag == 0)
                {
                    right = q[i].r;
                    flag = 1;

                }
        
                maxx = q[i].r;
                h = i;
                if(maxx >=m)
                {
                    if(h!=a[p-1])
                    {
                        a[p] = h;
                        p++;
                    }
                    break;
                }
            }
            else if(q[i].l>right && right!=0)
            {
                right = q[h].r;
                if(h!=a[p-1])
                {
                   
                    a[p] = h;
                    p++;
                }


                if(q[i].r>maxx)
                {
                    maxx = q[i].r;
                    h = i;
                    if(i == n-1)
                    {
                        a[p] = h;
                        p++;
                    }
                }
            }
        }

        if(p == 0)
        {
            printf("0\n");
        }
        else
        {
            printf("%d\n",p);
            for(int i=0; i<p; i++)
            {
                printf("%d %d\n",q[a[i]].l,q[a[i]].r);
            }
        }
        if(T)
        {
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值