Minimal coverage(贪心 区间覆盖)

Given several segments of line (int the X axis) with coordinates [Li
, Ri
]. You are to choose the minimal
amount of them, such they would completely cover the segment [0, M].
Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”
(|Li
|, |Ri
| ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair
‘0 0’.
Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line
segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0
Sample Output
0
1
0 1

给你一个数m,然后给你几个区间,让你求这几个区间中能够覆盖[0,m]的最小个数.
明显的贪心.我们按着结尾的大小,由大到小去将区间排序…然后一个一个的去查询,并且随时更新区间.
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

struct node{
	int start;
	int end;
}p[100005],q[100010];
int cmp(const node &a,const node &b)
{
	return a.end>b.end;
}
int s=0;
int e;


int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		s=0;
		scanf("%d",&e);
		int cnt=0;
		while(scanf("%d%d",&p[cnt].start,&p[cnt].end),p[cnt].end+p[cnt].start)
		{
			cnt++;
		}
		sort(p,p+cnt,cmp);
		int ant=0;
		int i;
		while(s<e)
		{
			for(i=0;i<cnt;i++)
			{
				if(p[i].start<=s&&p[i].end>s)
				{
					s=p[i].end;
					q[ant++]=p[i];
					break;
				}
			}
			if(i==cnt) break;
		}
		if(s<e) printf("0\n");
		else 
		{
			printf("%d\n",ant);
			for(i=0;i<ant;i++)
			{
				printf("%d %d\n",q[i].start,q[i].end);
			}
		}
		if(t) cout<<endl; 
	}
}

努力加油a啊,(o)/~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值