uva 10020 - Minimal coverage

Minimal coverage

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1
贪心求最少线段区间覆盖
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
struct node
{
 int x,y;
}a[100001],b[100001];
int cmp(node a,node b)
{
 return a.x<b.x;
}
int main()
{
 int max,pos,i,begin,end,m,n,sum,f,posmax,t;
 scanf("%d",&t);
 while (t--) 
 {
 scanf("%d",&m);
 n=0;
 while (scanf("%d%d",&begin,&end))
 {
  if (begin==0&&end==0) break;
  if (end>=0)
  {
   a[n].x=begin;
   a[n].y=end;
   ++n;
  }
 }
 sort(a,a+n,cmp);
 if (a[0].x>0) printf("0\n");//开始漏了没判断第一条线段就不能覆盖到0,wrongY-Y;
 else
 {
 pos=0; max=0; sum=1;
 while (pos+1<n&&a[pos+1].x<=0)//pos+1<N防止数组越界,还真有所有数据都从小于0开始的,re Y-Y;
 {
  ++pos;
  if (a[pos].y>a[max].y) max=pos;
 }
 pos=max; b[1].x=a[pos].x; b[1].y=a[pos].y;
 while (pos<n && b[sum].y<m) 
 {
  f=1; posmax=max;
  while (pos+1<n && a[pos+1].x<=a[max].y)
  {
  f=0;
   ++pos;
   if (a[pos].y>a[posmax].y) posmax=pos;
  }
  if (f) break;
  max=posmax;
  ++sum;
  b[sum].x=a[max].x;
  b[sum].y=a[max].y;
 }
 if (b[sum].y>=m) 
 {
  printf("%d\n",sum);
  for (i=1;i<=sum;i++)
  printf("%d %d\n",b[i].x,b[i].y);
 }else printf("0\n");
 }
 if (t) printf("\n");
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值