UVA550 Multiplying by Rotation


 Multiplying by Rotation 

Warning: Not all numbers in this problem are decimal numbers!


Multiplication of natural numbers in general is a cumbersome operation. In somecases however the product can be obtained by moving the last digit to the front.


Example: 179487 * 4 = 717948


Of course this property depends on the numbersystem you use, in the aboveexample we used the decimal representation. In base 9 we have a shorter example:


17 * 4 = 71 (base 9)


as (9 * 1 + 7) * 4 = 7 * 9 + 1

Input 

The input for your program is a textfile. Each line consists of three numbers separated by a space:the base of the number system, the least significant digit of the first factor, and the second factor.This second factor is one digit only hence less than the base. The input file ends with the standardend-of-file marker.

Output 

Your program determines for each input line the number of digits of the smallest first factor withthe rotamultproperty. The output-file is also a textfile. Each line contains the answer for thecorresponding input line.

Sample Input 

10 7 4
9 7 4
17 14 12

Sample Output 

6
2
4


题目意思就是一个数乘以另一个数得到的结果是自己本身最后以为数变到开头。如 179487 × 4 = 717948;

但这题并不是让你算10进制,而是任意n进制。

题目给的三个数分别是 n进制,要使乘完后最后一位变成第一位的那个乘数的最后一位,和要乘的数。。

思路就是采用小学生乘法模拟,不过注意是满n进1.按第一个样例,最后一位7乘以4为28!=7;那就下一位 ((28 % 10)+(28 /10)) × 4是不是等于7.。
循环到等于那最后一位为止。。。

AC代码如下:

#include<iostream>
using namespace std;

int main () {
	int x,y,z;
	int count;
	int temp;
	while (cin >>x >>y >>z) {
        count = 1;
		temp = y * z;
		while (temp != y ) {
		    count++;
			temp = (temp % x) * z + temp / x;
		}

		cout << count<<endl;
	}


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值