1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.22 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6


#include<stdio.h>
#include<malloc.h>
#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
typedef struct LinkNode *link;
struct LinkNode{
	int expo;
	double index;
}; 
map<int ,double> m;
LinkNode number1[10];
LinkNode number2[10];
vector<LinkNode> v;
bool compare1(LinkNode a,LinkNode b){
	return a.expo>b.expo;
	
}
int main(){
	int N,M;
	cin>>N;
	int i,j;
	int exp;
	double index;
	map<int ,double>::iterator it;
	for(i=0;i<N;i++){
		cin>>number1[i].expo>>number1[i].index;
	}
	cin>>M;
	for(i=0;i<M;i++){
		cin>>number2[i].expo>>number2[i].index;
	}
	for(i=0;i<N;i++){
		for(j=0;j<M;j++){
			it=m.find(number1[i].expo+number2[j].expo);
			if(it!=m.end())
			it->second+=number1[i].index*number2[j].index;
			else
			m.insert(pair<int,double>(number1[i].expo+number2[j].expo,number1[i].index*number2[j].index));
		}
	}
	//sort(m.begin(),m.end(),compare1);
	for(it=m.begin();it!=m.end();it++){
		if(it->second!=0){
			LinkNode l;
			l.expo=it->first;
			l.index=it->second;
		v.push_back(l);
	}
	}
	sort(v.begin(),v.end(),compare1);
	cout<<v.size();
	for(i=0;i<v.size();i++){
		printf(" %d %.1f",v[i].expo,v[i].index);
	}
}
感想:这道题最好是用map,然后把非零项添加到线性容器vector中,然后再自定义排序就可以出来
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值