1033. To Fill or Not to Fill (25)(加深对贪心的理解!!!)

1033. To Fill or Not to Fill (25)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

#include<iostream>
#include<algorithm>
using namespace std;
struct station{
	double price;
	int distance;
};
bool com1(const station &a,const station &b){
	return a.distance<b.distance;
}
int main(){
	int C,D,N,M;
	cin>>C>>D>>N>>M;
	int i,t;
	double oil=0,money_all=0;
	station *s=(station*)malloc((M+1)*sizeof(struct station));
	for(i=0;i<M;i++)
		scanf("%lf %d",&s[i].price,&s[i].distance);
	s[M].distance=D;s[M].price=0;
	sort(s,s+M,com1);
	if(s[0].distance!=0){//特殊情况 
		printf("The maximum travel distance = 0.00");
		return 0;
	}
	while(1){
		int start=t;
		if(s[start+1].distance-s[t].distance>C*N){
			if(D-s[t].distance<=C*N){
				money_all+=(D-s[t].distance-oil)*s[t].price;
				printf("%.2f",(money_all)*1.0/N*1.0);
				return 0;
			}
			else{
				printf("The maximum travel distance = %.2f",(s[t].distance+C*N*1.0));
				return 0;
			}
		}
		while(start<M&&s[++start].distance-s[t].distance<=C*N)
			if(s[start].price<s[t].price){
				if(oil>(s[start].distance-s[t].distance))
				oil-=s[start].distance-s[t].distance;
				else{
				money_all+=(s[start].distance-s[t].distance-oil)*s[t].price;
				oil=0;
				}
				t=start;
				break;
			}
		if(s[start].distance-s[t].distance>C*N){
			money_all+=(C*N-oil)*s[t].price;
			oil=C*N-(s[start-1].distance-s[t].distance);
			t=start-1;
		}
	}
}

感想:

1.通过这道题理解什么事真正的贪心算法

2。用cin会超时

3.做法

局部最优解,如果能到的站点都是价格高的,那就选择加满油去最远的那个,如果有价格低的那就加刚好能到那里的油区那里,一直重复就能到达终点,终点的价格设置为0,保证它 的优先级。

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值