PAT --- 1009.Product of Polynomials (25 分)

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×BA\times BA×B where AAA and BBB are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KKK N1N_1N1 aN1a_{N_1}aN1 N2N_2N2 aN2a_{N_2}aN2 ... NKN_KNK aNKa_{N_K}aNK

where KKK is the number of nonzero terms in the polynomial, NiN_iNi and aNia_{N_i}aNi (i=1,2,⋯,Ki=1, 2, \cdots , Ki=1,2,,K) are the exponents and coefficients, respectively. It is given that 1≤K≤101\le K \le 101K10, 0≤NK<⋯<N2<N1≤10000 \le N_K < \cdots < N_2 < N_1 \le 10000NK<<N2<N11000.

Output Specification:

For each test case you should output the product of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

思路

使用hash_map数据结构保存数据,m->first保存指数,m->second保存系数,然后进行数据处理,最后逆序输出。
一开始测试点0不过,原因是没有考虑系数和为负数的情况。详情如下:
0号案例测的点是正负抵消掉产生的0不在答案里输出

代码

#include <iostream>
#include <map>
using namespace std;

int main() {
	double k1, k2, n, an;
	map<double, double> hash_k1, hash_k2, hash_k3;
	cin >> k1;
	for (int i = 0; i < k1; i++) {	// 存入第一行
		cin >> n >> an;
		hash_k1[n] = an;
	}		
	cin >> k2;
	for (int i = 0; i < k2; i++) {	// 存入第二行
		cin >> n >> an;
		hash_k2[n] = an;
	}
	for (auto i : hash_k1) {		// 数据相乘
		for (auto j : hash_k2) {
			hash_k3[i.first + j.first] += i.second * j.second;
			if (hash_k3[i.first + j.first] == 0)	//没有此行代码 测试点0不过
				hash_k3.erase(i.first + j.first);
		}
	}
	printf("%d", hash_k3.size());	// 输出
	for (auto it = hash_k3.rbegin(); it != hash_k3.rend(); it++) {
		int n1 = it->first;
		double n2 = it->second;
		printf(" %d %.1f", n1, n2);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值