POJ 1050 To the Max(动态规划-最大子段和)

To the Max
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 49148
Accepted: 26030

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

题目大意:求一个最大为100*100矩阵中的子矩阵中元素之和的最大值

首先,解这道题要有求最大子段和的基础,如给你一个数组a,求数组中a[i]+a[i+1]+...+a[j]的最大值

                   解法很简单,参考如下:

                   int b=0,sum=-100000000;  
                       for(int i=0;i<n;i++)  
                       {  
                           if(b>0) b=b+a[i];  
                           else     b=a[i];  
                           if(b>sum) sum=b;    
                       }  

这道题目就是如果最优解左起第i列,右止于第j列,那么我们相当于把这些列的对应位加和,成为一列,对该列求最大

状态转移方程为

dp[i][j][k]=max(dp[i-1][j][k]+sum,sum);第 i 行 j 到 k 列的最大和

AC代码
#include<iostream>
#include<cstdio>
using namespace std;
int dp[105][105][105];
int f[105][102];
int main(){
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			scanf("%d",&f[i][j]);
		}
	}
	int ans=0;
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			int sum=0;
			for(int k=j;k<=n;k++){
				sum+=f[i][k];
				dp[i][j][k]=max(dp[i-1][j][k]+sum,sum);
				ans=max(ans,dp[i][j][k]);
			}
		}
	}
	printf("%d\n",ans);
	return 0;
}



  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值