HDU 1071 The area(抛物线与直线围成的面积)

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10809    Accepted Submission(s): 7619


Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.




 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
  
  
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
  
  
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 

题目大意:给你三个点,P1是抛物线的顶点,P2和P3是抛物线和直线的交点,求抛物线和直线围成的面积。

抛物线方程为 x^2a+xb+c=y
那么
x1^2a+x1b+c=y1

x2^2a+x2b+c=y2
x3^2a+x3b+c=y3
D=x1^2*x2-x1^2*x3-x2^2*x1+x2^2*x3+x3^2*x1-x3^2*x2
D1=y1*x2-y1*x3-y2*x1+y2*x3+y3*x1-y3*x2
D2=x1^2*y2-x1^2*y3-x2^2*y1+x2^2*y3+x3^2*y1-x3^2*y2
D3=x1^2*y3*x2-x1^2*y2*x3-x2^2*y3*x1+x2^2*y1*x3+x3^2*y2*x1-x3^2*y1*x2
a=D1/D
b=D2/D
c=D3/D
对于直线方程 y=ax+b;
a=(y3-y2)/(x3-x2);
b=y2-a*x2;
如上直接求便可
以下是AC代码
#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		double x1,x2,x3,y1,y2,y3;
		scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
		double a,b,c,a1,b1;
		double d=x1*x1*x2-x1*x1*x3-x2*x2*x1+x2*x2*x3+x3*x3*x1-x3*x3*x2;
		double d1=y1*x2-y1*x3-y2*x1+y2*x3+y3*x1-y3*x2;
		double d2=x1*x1*y2-x1*x1*y3-x2*x2*y1+x2*x2*y3+x3*x3*y1-x3*x3*y2;
		double d3=x1*x1*y3*x2-x1*x1*y2*x3-x2*x2*y3*x1+x2*x2*y1*x3+x3*x3*y2*x1-x3*x3*y1*x2;
		a=d1/d;
		b=d2/d;
		c=d3/d;
		a1=(y3-y2)/(x3-x2);
		b1=y2-a1*x2;
		double ans=a*x3*x3*x3/3.0+((b-a1)/2.0)*x3*x3+(c-b1)*x3;
		ans-=a*x2*x2*x2/3.0+((b-a1)/2.0)*x2*x2+(c-b1)*x2;
		printf("%.2f\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值