Is Derek lying?
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 0 Accepted Submission(s): 0
Problem Description
Derek
and
Alfia
are good friends.
Derek
is Chinese,and
Alfia
is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of
N
choice questions and each question is followed by three choices marked “
A
” “
B
” and “
C
”.Each question has only one correct answer and each question is worth
1
point.It means that if your answer for this question is right,you can get
1
point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell
Derek
the total score of him and
Alfia
.Then
Alfia
will ask
Derek
the total score of her and he will tell her: “My total score is
X
,your total score is
Y
.”But
Derek
is naughty,sometimes he may lie to her. Here give you the answer that
Derek
and
Alfia
made,you should judge whether
Derek
is lying.If there exists a set of standard answer satisfy the total score that
Derek
said,you can consider he is not lying,otherwise he is lying.
Input
The first line consists of an integer
T
,represents the number of test cases.
For each test case,there will be three lines.
The first line consists of three integers N , X , Y ,the meaning is mentioned above.
The second line consists of N characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of Derek for each question.
The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.
Data Range: 1≤N≤80000 , 0≤X,Y≤N, ∑Ti=1N≤300000
For each test case,there will be three lines.
The first line consists of three integers N , X , Y ,the meaning is mentioned above.
The second line consists of N characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of Derek for each question.
The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.
Data Range: 1≤N≤80000 , 0≤X,Y≤N, ∑Ti=1N≤300000
Output
For each test case,the output will be only a line.
Please print “ Lying ” if you can make sure that Derek is lying,otherwise please print “ Not lying ”.
Please print “ Lying ” if you can make sure that Derek is lying,otherwise please print “ Not lying ”.
Sample Input
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
Sample Output
Not lying Lying
题目大意:
给你两个人的答案,问给出的分数是否合理。
解题思路:
a=两人回答相同的数目
b=两人回答不同的数目
先假设分数是合理的
1、两人分数较低的分数< a ,说明回答相同的部分有回答错误的,那么两人分数的差值必须比b少才会合理,否则不合理
2、两人分数较低的分数>=a,说明回答相同的部分都是正确的,那么两人回答正确但回答不一样的数目有 x - a + y - a,这个数目必须小于b才合理,不然不合理。
AC代码
#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
char xx[80000],yy[80000];
int main(){
int t;
scanf("%d",&t);
while(t--){
int n,x,y;
scanf("%d%d%d",&n,&x,&y);
scanf("%s",xx);
scanf("%s",yy);
int a=0;
for(int i=0;i<n;i++){
if(xx[i]==yy[i])a++;
}
int b=n-a;
if(a>=min(x,y)){
if(abs(x-y)>b){
printf("Lying\n");
continue;
}
else{
printf("Not lying\n");
continue;
}
}
if(a<min(x,y)){
if(x-a+y-a<=b){
printf("Not lying\n");
continue;
}
else{
printf("Lying\n");
continue;
}
}
}
return 0;
}