hdu 5200 Trees 排序+思维? ★★☆

Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1282    Accepted Submission(s): 398


Problem Description
Today CodeFamer is going to cut trees.There are  N  trees standing in a line. They are numbered from  1  to  N . The tree numbered  i  has height  hi . We say that two uncutted trees whose numbers are  x  and  y  are in the same block if and only if they are fitting in one of blow rules:

1)x+1=y or y+1=x;

2)there exists an uncutted tree which is numbered  z , and  x  is in the same block with  z , while  y  is also in the same block with  z .

Now CodeFamer want to cut some trees whose height is not larger than some value, after those trees are cut, how many tree blocks are there?
 

Input
Multi test cases (about  15 ).

For each case, first line contains two integers  N  and  Q  separated by exactly one space, N indicates there are  N  trees,  Q  indicates there are  Q  queries.

In the following  N  lines, there will appear  h[1],h[2],h[3],,h[N]  which indicates the height of the trees.

In the following  Q  lines, there will appear  q[1],q[2],q[3],,q[Q]  which indicates CodeFamer’s queries.

Please process to the end of file.

[Technical Specification]

1N,Q50000

0h[i]1000000000(109)

0q[i]1000000000(109)
 

Output
For each  q[i] , output the number of tree block after CodeFamer cut the trees whose height are not larger than  q[i] .
 

Sample Input
  
  
3 2 5 2 3 6 2
 

Sample Output
  
  
0 2
Hint
In this test case, there are 3 trees whose heights are 5 2 3. For the query 6, if CodeFamer cuts the tree whose height is not large than 6, the height form of left trees are -1 -1 -1(-1 means this tree was cut). Thus there is 0 block. For the query 2, if CodeFamer cuts the tree whose height is not large than 2, the height form of left trees are 5 -1 3(-1 means this tree was cut). Thus there are 2 blocks.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5599  5598  5597  5596  5595 
 




#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI (4.0*atan(1.0))
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   ind<<1,le,mid
#define rson    ind<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 50000+20    ;
//const int maxm=    ;
 
 
int n,q;
 
int sum[maxn];
bool vis[maxn];
struct Node
{
   int hei,ind;
 
 
}a[maxn];
 
bool cmp(Node x,Node y)
{
    return x.hei>y.hei;
}
 
int search(int x)
{
    int le=1,ri=n;
    while(le<=ri)
    {
        int mid=(le+ri)/2;
        if(a[mid].hei<=x) ri=mid-1;
        else     le=mid+1;
    }
    return ri;
}
int main()
{
    int x;
  while(~scanf("%d%d",&n,&q))
  {
      FOR1(i,n)  scanf("%d",&a[i].hei),a[i].ind=i;
      sort(a+1,a+1+n,cmp);
 
      memset(vis,0,sizeof vis);
      sum[0]=0,sum[1]=1;
 
      vis[ a[1].ind ] =1;
 
 
      for(int i=2;i<=n;i++)
      {
           x=a[i].ind;
          if( (vis[x-1]&& !vis[x+1]) || (!vis[x-1]&& vis[x+1])  )
          {
              sum[i]=sum[i-1];
          }
          else if(  vis[x-1]&&vis[x+1]   )
          {
              sum[i]=sum[i-1]-1;
          }
          else
          {
              sum[i]=sum[i-1]+1;
          }
          vis[x]=1;
      }
      /*
      for(int i=1;i<=n;i++)
      {
          cout<<i<<" "<<sum[i]<<endl;
      }*/
 
      while(q--)
      {
          scanf("%d",&x);
          int p=search(x);
          printf("%d\n",sum[p]);
      }
  }
 
    return 0;
}
/*
6  3
12 7 10 15 7 8
7
10
12
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值