2016ACM亚洲赛沈阳站 E - 暴搜

Counting Cliques

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 75    Accepted Submission(s): 0


Problem Description
A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph. 
 

Input
The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.
 

Output
For each test case, output the number of cliques with size S in the graph.
 

Sample Input
  
  
3 4 3 2 1 2 2 3 3 4 5 9 3 1 3 1 4 1 5 2 3 2 4 2 5 3 4 3 5 4 5 6 15 4 1 2 1 3 1 4 1 5 1 6 2 3 2 4 2 5 2 6 3 4 3 5 3 6 4 5 4 6 5 6
 

Sample Output
  
  
3 7 15
什么叫暴搜????
就是基本不用剪枝,所有情况都搜出来;
题意:给一个无向图,问大小为S的团有多少个,什么叫团?团就是完全图,大小为S的团就是由S个点组成的完全图
怎么写呢??
看题意有100个点,点很少!!!,暴搜一遍吧,但是有可能出现重复啊,怎么做,用一个数组记录已经存在的团的大小,数组是一个由小到大
的数组,即前点要进入团时,判断该节点是否比团内所有点大,这样就避免了重复,判断大小时只需要判断进最后一个点是否比当前点小就行了
所以建图是可以按照 小的点指向大的点得方式建图,这样会少很多不必要的搜索操作,
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
using namespace std;
int n,m,k;
const int maxm=2050,maxn=105;
int mp[maxn][maxn];

struct Edge
{
    int to,next;
}edge[maxm];
int tot,head[maxn];
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}
int ans;
void dfs(int a[],int u)
{
    /// a 数组保存团
    ///a[0] 表示团大小
    if(a[0]==k)
    {
        ans++;
        return ;
    }
    int v,flag;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].to;
            flag=1;
            for(int j=1;j<=a[0];j++)
            {
                if(mp[v][a[j]]==0)///是否v 与团内所有点都有边
                 {
                     flag=0;
                     break;
                 }
            }
            if(flag)///是,全有边
            {
                 a[0]++;
                 a[a[0]]=v;
                 dfs(a,v);
                 a[0]--;
            }
    }
}
int main()
{
    int T;
    int u,v;
    int sle[maxn];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(mp,0,sizeof(mp));
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            if(u>v)///建议个小的节点指向大的节点 的图
                swap(u,v);
            add(u,v);
            mp[u][v]=mp[v][u]=1;/// 数组保存好判断是否存在边
        }
        ans=0;
        for(int i=1;i<=n;i++)/// 爆搜,在每个点出发一次
        {
            sle[0]=1;
            sle[1]=i;
            dfs(sle,i);
        }
        printf("%d\n",ans);
    }
    return 0;
}





 

Statistic |  Submit |  Clarifications |  Back


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值