Counting Cliques HDU - 5952 (暴力)

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph. 

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output

For each test case, output the number of cliques with size S in the graph.

Sample Input

3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6

Sample Output

3
7
15

思路 只枚举这个点所能到达的点(只有20个);

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int a[110][110];
int n,p,len,pp;
int x[11];
int ans;
vector<int> q[110];
void dfs(int xx,int cnt)
{
    if(cnt==len)
    {
        ans++;
        return ;
    }
    int i,j,f;
    for(i=0;i<q[xx].size();i++)
    {
        f = 1;
        int u = q[xx][i];
        for(j=1;j<=cnt;j++)
        {
            if(a[x[j]][u] == 0)
            {
                f = 0;
                break;
            }
        }
        if(f)
        {
            x[cnt+1] = u;
            dfs(u,cnt+1);
        }
    }
}

int main()
{
    int t,m,i,j,u,v;
    scanf("%d",&t);
    while(t--)
    {
        ans = 0;
        scanf("%d%d%d",&n,&m,&len);
        for(i=1;i<=n;i++)
        {
            q[i].clear();
        }
        memset(a,0,sizeof(a));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            if(u > v) swap(u,v);
            q[u].push_back(v);
            a[v][u] = 1;
            a[u][v] = 1;

        }

        for(i=1;i<=n;i++)
        {
            x[1] = i;
            dfs(i,1);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值