poj 1716-Integer Intervals


Integer Intervals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11884 Accepted: 5017

Description

An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. 
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.

Input

The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.

Output

Output the minimal number of elements in a set containing at least two different integers from each interval.

Sample Input

4
3 6
2 4
0 2
4 7

Sample Output

4

输入输出:

输入:n,表示有n个区间,接下的n行,输入a,b,表示区间[a,b];

输出:在这些区间里面取得最少的元素,使得这些元素满足:包含每一个区间至少两个不同的元素


题目分析:

用数组d[i]表示从点0到i-1所包含的关键点的个数

那么题目中的条件转化为d[b+1] - d[a] >= 2 也就是: d[a] - d[b+1] <= -2; //注意:这里都是小于的格式,若是a-b > x,就转化为b-a < -x.

并且可以得到:d[i+1] - d[i] <= 1 和 d[i+1] - d[i] >= 0;  也就是:d[i] - d[I+1] <= 0;

建图,求d[max] - d[min]即可(max和min表示输入数据中的最大点和最小点)


代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std ;
#define N 10010
#define INF 1<<30

struct Edge{
    int v, w, next ;
}e[N<<2] ;

int head[N], cnt ;
int l, r ;
bool vis[N];
int s[N], d[N] ;

void init(){
    memset(vis, 0, sizeof(vis)) ;
    memset(head, -1, sizeof(head)) ;
    cnt = 0 ;
}

void add(int u, int v, int w){
    e[cnt].v = v ;
    e[cnt].w = w ;
    e[cnt].next = head[u] ;
    head[u] = cnt++ ;
}

void spfa(){
    for(int i=l; i<r; i++)  d[i] = INF ;
    int h = 0;
    s[h++] = r ;
    d[r] = 0;
    while(h){
        int u = s[--h] ;
        vis[u] = 0 ;
        for(int i=head[u]; i!=-1; i=e[i].next){
            if(d[e[i].v] > d[u] + e[i].w){
                d[e[i].v] = d[u] + e[i].w ;
                if(!vis[e[i].v]){
                    vis[e[i].v] = 1 ;
                    s[h++] = e[i].v ;
                }
            }
        }
    }
}

int main(){
    int n ;
    while(scanf("%d", &n) == 1){
        init() ;
        l = 10000, r = 0 ;
        for(int i=1; i<=n; i++){
            int a, b ;
            scanf("%d %d", &a, &b) ;
            add(++b, a, -2) ;
            r = max(r, b + 1) ;
            l = min(l, a) ;
        }
        for(int i=l; i<r; i++){
            add(i, i+1, 1) ;
            add(i+1, i, 0) ;
        }
        spfa() ;
        printf("%d\n", d[r] - d[l]) ;
    }
    return 0 ;
}




在使用Python来安装geopandas包时,由于geopandas依赖于几个其他的Python库(如GDAL, Fiona, Pyproj, Shapely等),因此安装过程可能需要一些额外的步骤。以下是一个基本的安装指南,适用于大多数用户: 使用pip安装 确保Python和pip已安装: 首先,确保你的计算机上已安装了Python和pip。pip是Python的包管理工具,用于安装和管理Python包。 安装依赖库: 由于geopandas依赖于GDAL, Fiona, Pyproj, Shapely等库,你可能需要先安装这些库。通常,你可以通过pip直接安装这些库,但有时候可能需要从其他源下载预编译的二进制包(wheel文件),特别是GDAL和Fiona,因为它们可能包含一些系统级的依赖。 bash pip install GDAL Fiona Pyproj Shapely 注意:在某些系统上,直接使用pip安装GDAL和Fiona可能会遇到问题,因为它们需要编译一些C/C++代码。如果遇到问题,你可以考虑使用conda(一个Python包、依赖和环境管理器)来安装这些库,或者从Unofficial Windows Binaries for Python Extension Packages这样的网站下载预编译的wheel文件。 安装geopandas: 在安装了所有依赖库之后,你可以使用pip来安装geopandas。 bash pip install geopandas 使用conda安装 如果你正在使用conda作为你的Python包管理器,那么安装geopandas和它的依赖可能会更简单一些。 创建一个新的conda环境(可选,但推荐): bash conda create -n geoenv python=3.x anaconda conda activate geoenv 其中3.x是你希望使用的Python版本。 安装geopandas: 使用conda-forge频道来安装geopandas,因为它提供了许多地理空间相关的包。 bash conda install -c conda-forge geopandas 这条命令会自动安装geopandas及其所有依赖。 注意事项 如果你在安装过程中遇到任何问题,比如编译错误或依赖问题,请检查你的Python版本和pip/conda的版本是否是最新的,或者尝试在不同的环境中安装。 某些库(如GDAL)可能需要额外的系统级依赖,如地理空间库(如PROJ和GEOS)。这些依赖可能需要单独安装,具体取决于你的操作系统。 如果你在Windows上遇到问题,并且pip安装失败,尝试从Unofficial Windows Binaries for Python Extension Packages网站下载相应的wheel文件,并使用pip进行安装。 脚本示例 虽然你的问题主要是关于如何安装geopandas,但如果你想要一个Python脚本来重命名文件夹下的文件,在原始名字前面加上字符串"geopandas",以下是一个简单的示例: python import os # 指定文件夹路径 folder_path = 'path/to/your/folder' # 遍历文件夹中的文件 for filename in os.listdir(folder_path): # 构造原始文件路径 old_file_path = os.path.join(folder_path, filename) # 构造新文件名 new_filename = 'geopandas_' + filename # 构造新文件路径 new_file_path = os.path.join(folder_path, new_filename) # 重命名文件 os.rename(old_file_path, new_file_path) print(f'Renamed "{filename}" to "{new_filename}"') 请确保将'path/to/your/folder'替换为你想要重命名文件的实际文件夹路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值