POJ - 1716 Integer Intervals(贪心)



An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. 
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.
Input
The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.
Output
Output the minimal number of elements in a set containing at least two different integers from each interval.
Sample Input
4
3 6
2 4
0 2
4 7
Sample Output
4
         

               给出数轴上的n个区间,每个区间都是连续的int区间。

              现在要在数轴上任意取一堆元素,构成一个元素集合V

              要求每个区间和元素集合V的交集至少有两个不同的元素

              求集合V最小的元素个数。

            

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int x;
    int y;
}p[11000];
int cmp(node a,node b)
{
    if(a.y==b.y) return a.x>b.x;
    else return a.y<b.y;
}
int main()
{
    int n,sum=2,a,b,i;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d%d",&p[i].x,&p[i].y);
    sort(p,p+n,cmp);
    a=p[0].y-1;
    b=p[0].y;
    for(i=1;i<n;i++)
    {
        if(b<p[i].x)
        {
            sum=sum+2;
            a=p[i].y-1;
            b=p[i].y;
        }
        if(a<p[i].x&&b>=p[i].x)
        {
            sum=sum+1;
            a=b;
            b=p[i].y;
        }
        if(a>=p[i].x&&b>=p[i].x)
            continue;
    }
    printf("%d\n",sum);
}


             

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值