01背包第K最优解 HDU - 2639 


The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.


Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).


Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output

12
2
0

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int t,n,v,K;
int dp[1005][35];
int a[35];
int b[35];
int value[105];
int weight[105];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&v,&K);
        for(int i=1; i<=n; i++)
            scanf("%d",&value[i]);
        for(int i=1; i<=n; i++)
            scanf("%d",&weight[i]);

        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=v; j>=weight[i]; j--) //在背包为 j 的时候,记录下选择第 i 个物品和不选择第 i 个物品的时候的值
                                            //然后将两个值的最大值“归并”到 dp 数组中
            {
                 for(int k=1; k<=K; k++)     //多加一维用来找第K最优解
                {
                    a[k]=dp[j-weight[i]][k]+value[i];
                    b[k]=dp[j][k];
                }
                a[K+1]=-1;b[K+1]=-1;
                int x=1,y=1,c=1;
                while((a[x]!=-1||b[y]!=-1) && c<=K)  //每一次放进一个骨头找最优解
                {
                    if(a[x]>b[y]) dp[j][c]=a[x],x++;
                    else dp[j][c]=b[y],y++;
                    if(dp[j][c]!=dp[j][c-1]) c++;   //找到最优解才更新
                }

            }
        printf("%d\n",dp[v][K]);

    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值