hdoj1009FatMouse' Trade(贪心)


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 
题意:
康康准备了 M 斤的食物, 准备跟舍长交换哲学之宝 ♂
舍长有 N 个房间. 第 i 个房间有 J[i] 的 ♂ 需要 F[i] 斤的食物. 康康可以不换完整个房间的♂ ,
他可以用 F[i]* a% 的食物 换 J[i]* a% 的 ♂ 

现在给你一个实数 M 问你康康最多能获得多少的 ♂

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	double a;
	double b;
	double c;
}arr[1100];
bool cmp(node x,node y)
{
	return x.c>y.c;
}
int main()
{
	int m,i;
	double n;
	double sum;
	while(scanf("%lf%d",&n,&m)!=EOF)
	{
		if(n==-1&&m==-1)
		break;
		sum=0;
		for(i=0;i<m;i++){
			scanf("%lf %lf",&arr[i].a,&arr[i].b);
			arr[i].c=arr[i].a/arr[i].b;
		}
		sort(arr,arr+m,cmp);
		for(i=0;i<m;i++)
		{
			if(n>=arr[i].b)
			{
			sum+=arr[i].a;
			n-=arr[i].b;	
			}
			else
			{
				sum+=n*arr[i].c;
				n=0;//刚开始wa是因为这一行没加.
			}
			
		}
		printf("%.3lf\n",sum);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值