HDOJ-1009-FatMouse' Trade

9 篇文章 0 订阅

FatMouse’ Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66473 Accepted Submission(s): 22591

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2

20 3
25 18
24 15
15 10

-1 -1

Sample Output
13.333
31.500

一个简单的贪心问题。
此题只要注意几个比较坑的数据就行了:
1 0
0 1
1.000

0 1
0.000

4 5
100 5
20 2
30 0
10 0
104.000

只要处理好这几个数字即可。
代码如下:

#include <cstdio>
#include <algorithm>
#include<stdint.h>
#include<math.h>
#include<string.h>
struct q{
    double j,f,k;
}p[1005];
bool cmp(q x,q y){
    return x.k>y.k;
}
using namespace std;
int main(){
    int m,n;
    double a;
    while(~scanf("%d%d",&m,&n)&&m!=-1||n!=-1){
        a=0.0;
        if(!n){
            printf("%.3f\n",a);
            continue;
        }
        memset(p,0,sizeof(p));
        for(int i=0;i<n;i++){
            scanf("%lf %lf",&p[i].j,&p[i].f);
            if(!p[i].f){
                a+=p[i].j;
                p[i].j=0;
                continue;
            }
            p[i].k=p[i].j/p[i].f;
        }
        sort(p,p+n,cmp);
        for(int i=0;i<n;i++){
            if(p[i].f>m){
                a+=p[i].k*m;
                break;
            }
            else {
                a+=p[i].j;
                m-=p[i].f;
            }
        }
        printf("%.3lf\n",a);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值