NYOJ 211 tree(二叉树的遍历与创建)

B - Tree Recovery
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
 D 
                                              / \

                                             /   \

 B     E 
                                           / \     \

                                          /   \     \

 A     C     G 
                                                    /

                                                   /

 F 

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED

CDAB

题意:给出二叉树的前序和中序的遍历顺序,求这个二叉树后序遍历的顺序

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef struct node{
	char root;
	struct node *left,*right;
}node;
node *creat(char *pre,char *in,int len)//创建一个二叉树  *pre表示二叉树的根,*in表示中序 
{                                      //遍历的第一个节点,len表示二叉树的总节点数 
	int l;
	if(len<=0)
	return NULL;
	node *head=(node*)malloc(sizeof(node));
	  head->root=*pre;
	char *p;
	for(p=in;p!=NULL;p++)
	{
		if(*p==*pre)   //找到二叉树的根 
		break;
	}
	l=p-in;//求出二叉树左子树的节点数 
	head->left=creat(pre+1,in,l);//递归创建左子树 
	head->right=creat(pre+l+1,p+1,len-l-1);//递归创建右子树 
	return head;
}
void print(node *head)//二叉树后序输出函数 
{
	if(head==NULL)
	return ;
	print(head->left);
	print(head->right);
	printf("%c",head->root);
 } 
 int main()
 {
 	char pre[30],in[30];
 	node *head;
 	head=(node*)malloc(sizeof(node));
 	while(~scanf("%s %s",pre,in))
 	{
 		int len=strlen(pre);
 		head=creat(pre,in,len);
 		print(head);
 		printf("\n");
	 }
	 return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值