PAT 甲级 1110. Complete Binary Tree (25)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line “YES” and the index of the last node if the tree is a complete binary tree, or “NO” and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

#include <iostream>
#include <cstdio>
#include <string.h>
#include <queue>
#include <vector>
using namespace std;
struct Tree{
    int left;
    int right;
};
int main(){
    int n,root;
    scanf("%d",&n);
    vector<Tree> tree(n);
    vector<int> book(n);
    for(int i=0;i<n;i++){
            char l[3],r[3];
        scanf("%s %s",l,r);
    if(l[0]=='-'){
       tree[i].left=-1;
       }else{
        int temp=l[0]-'0';
        if(strlen(l)==2){
            temp=temp*10+(l[1]-'0');
        }
        tree[i].left=temp;
       }
       if(r[0]=='-'){
        tree[i].right=-1;
       }else{
           int temp=r[0]-'0';
           if(strlen(r)==2){
            temp=temp*10+(r[1]-'0');
           }
           tree[i].right=temp;
       }
       if(tree[i].left!=-1)
        book[tree[i].left]=1;
       if(tree[i].right!=-1)
        book[tree[i].right]=1;
    }
    for(int i=0;i<n;i++){
        if(book[i]==0){
            root=i;
            break;
        }
    }
    queue<int> q;
    q.push(root);
    int cnt=0;
    int lastnode=0;
    while(!q.empty()){
        int node=q.front();
        q.pop();
        if(node!=-1){
            lastnode=node;
            cnt++;
        }else{
            if(cnt!=n){
                printf("NO %d",root);
            }else
            printf("YES %d",lastnode);
            return 0;
        }
        q.push(tree[node].left);
        q.push(tree[node].right);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值