PAT-A1110. 二叉树-完全二叉树的判断

题目链接:https://www.patest.cn/contests/pat-a-practise/1110
Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line “YES” and the index of the last node if the tree is a complete binary tree, or “NO” and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:
YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:
NO 1

完全二叉树判断思路:层序遍历,一个完全二叉树中,当遍历到某个结点没有子结点时,那么它后面的所有结点都应该没有子结点。

#include <iostream>
#include <queue>
#include <cstring>
#include <string>
using namespace std;

struct BTree {
    int lchild,rchild;
};
BTree T[25];
bool notRoot[25];
int thisone = -1; // 层序遍历时当前访问的节点序数

bool LevelOrder(int root)
{
    queue<int> qt;
    qt.push(root);
    bool nochild = false;
    while (!qt.empty()) {
        thisone = qt.front();
        qt.pop();
        if(T[thisone].lchild!=-1){
            if(nochild)
                return false;
            qt.push(T[thisone].lchild);
        }
        else
            nochild = true;
        if(T[thisone].rchild!=-1){
            if(nochild)
                return false;
            qt.push(T[thisone].rchild);
        }
        else
            nochild = true;
    }
    return true;
}

int GetRootIndex()
{
    int i = 0;
    while (notRoot[i]) {
        ++i;
    }
    return i;
}

int main()
{
    memset(notRoot, 0, sizeof(notRoot));
    int num;
    cin >> num;
    for(int i = 0; i < num; ++i)
    {
        char str[3];
        int temp;
        scanf("%s", str);
        if(str[0] == '-') T[i].lchild = -1;
        else {
            sscanf(str, "%d", &temp);
            T[i].lchild = temp;
            notRoot[temp] = true;
        }

        scanf("%s", str);
        if(str[0] == '-') T[i].rchild = -1;
        else {
            sscanf(str, "%d", &temp);
            T[i].rchild = temp;
            notRoot[temp] = true;
        }

    }

    int rootIndex = GetRootIndex();

    if(LevelOrder(rootIndex))
        cout << "YES" << " " << thisone << endl;
    else
        cout << "NO" << " " << rootIndex << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是用C语言实现的代码: ```c #include <stdio.h> #include <stdlib.h> // 二叉树结点结构体 typedef struct TreeNode { int val; // 结点值 struct TreeNode* left; // 左子结点 struct TreeNode* right; // 右子结点 } TreeNode; // 插入结点 TreeNode* insert(TreeNode* root, int val) { if (root == NULL) { // 如果空树,则插入到根结点 TreeNode* node = (TreeNode*)malloc(sizeof(TreeNode)); node->val = val; node->left = NULL; node->right = NULL; return node; } if (val < root->val) { // 如果插入的值小于当前结点的值,则插入到左子树 root->left = insert(root->left, val); } else { // 否则插入到右子树 root->right = insert(root->right, val); } return root; } // 计算树的高度 int height(TreeNode* root) { if (root == NULL) return 0; int leftHeight = height(root->left); int rightHeight = height(root->right); return (leftHeight > rightHeight ? leftHeight : rightHeight) + 1; } // 打印二叉树 void printTree(TreeNode* root, int layer) { if (root == NULL) return; printTree(root->right, layer + 1); // 先打印右子树 for (int i = 0; i < layer - 1; i++) { printf(" "); } if (layer > 0) { printf(".--"); } printf("%d\n", root->val); printTree(root->left, layer + 1); // 再打印左子树 } int main() { TreeNode* root = NULL; // 根结点 int val; while (scanf("%d", &val) != EOF) { root = insert(root, val); // 插入结点 } int h = height(root); // 计算树的高度 printTree(root, h); // 打印二叉树 return 0; } ``` 输入样例: ``` 10 5 20 8 4 7 ``` 输出样例: ``` .---20 .--10 | `--8 | |--7 `--5 `--4 ``` 解释:该二叉树的结构如下: ``` 10 / \ 5 20 / \ 4 8 / 7 ``` 其中,叶子结点 4 和 7 的高度为 1,结点 5 和 8 的高度为 2,结点 10 的高度为 3,结点 20 的高度为 1。因此,树的高度为 3。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值