POJ2236Wireless Network(结构体,并查集)

15 篇文章 0 订阅
10 篇文章 0 订阅

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
代码:
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std; 
struct st{
	int xi;
	int yi;
	int s;
}a[1001];
int pre[1001];
int find(int x)
{
    return x == pre[x] ? x : find(pre[x]);
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	pre[fx]=fy;
 } 
int main()
{
	int i,n,m,j,ans,sta,end;
 	char q;
 	memset(a,0,sizeof(a));
 	memset(pre,0,sizeof(pre));
 	scanf("%d%d",&n,&m);
 	for(i=1;i<=n;i++)
 	{
 		scanf("%d%d",&a[i].xi,&a[i].yi);
 		pre[i]=i;
	 }
	 while(scanf("\n%c", &q)!=EOF)
	 {
	 	if(q=='O')
	 	{
	 		int w;
	 		scanf("%d",&w);
	 		a[w].s=1;
	 		for(i=1;i<=n;i++)
			 	{
			 		if(a[i].s==1&&i!=w)
			 			if((a[i].xi-a[w].xi)*(a[i].xi-a[w].xi)+(a[i].yi-a[w].yi)*(a[i].yi-a[w].yi)<=m*m)
			 			{
			 				join(i,w);
						 }
				 }
		 }
		 else if(q=='S')
		 {
		 	int sta,end;
		 	scanf("%d%d",&sta,&end);
		 	if(find(sta)==find(end))
		 	printf("SUCCESS\n");
		 	else
		 	printf("FAIL\n");
		 }
	 }
	return 0;
}


思路:并查集,对维修过的而且距离符合的电脑进行join,最后并查。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值