1203:单词分割

1203:单词分割


Description

从键盘输入一段英文,将其中的英文单词分离出来:已知单词之间的分隔符包括空格,问号、句号(小数点)和分号。 

Input

输入一行字符串 (字符不超过1000)

Output

将分割后的单词按行输出

Sample Input

There are apples; oranges and peaches on the table.

Sample Output

There
are
apples
oranges
and
peaches
on
the
table


#include<stdio.h>
#include<string.h>
int main()
{
    char ch[100];
    gets(ch);
    int i,n;
    n=strlen(ch);
    int temp=0;
    for(i=0;i<n;i++)
    {
        if(ch[i]=='\40'&&ch[i-1]<'A')
        {
           int j;
           for(j=temp;j<i-1;j++)
           {
               printf("%c",ch[j]);
 
           temp=i+1;
           }
       printf("\n");
        }
if(ch[i]=='\40'&&ch[i-1]>'A')
{
     int j;
           for(j=temp;j<i;j++)
           {
               printf("%c",ch[j]);
 
           temp=i+1;
           }
 
 
printf("\n");
    }
    }
int a;
for(a=temp;a<n-1;a++)
    printf("%c",ch[a]);
 
 
    return 0;
 
 
 
 
 
}
 






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值