1203:单词分割

1203:单词分割


Description

从键盘输入一段英文,将其中的英文单词分离出来:已知单词之间的分隔符包括空格,问号、句号(小数点)和分号。 

Input

输入一行字符串 (字符不超过1000)

Output

将分割后的单词按行输出

Sample Input

There are apples; oranges and peaches on the table.

Sample Output

There
are
apples
oranges
and
peaches
on
the
table


#include<stdio.h>
#include<string.h>
int main()
{
    char ch[100];
    gets(ch);
    int i,n;
    n=strlen(ch);
    int temp=0;
    for(i=0;i<n;i++)
    {
        if(ch[i]=='\40'&&ch[i-1]<'A')
        {
           int j;
           for(j=temp;j<i-1;j++)
           {
               printf("%c",ch[j]);
 
           temp=i+1;
           }
       printf("\n");
        }
if(ch[i]=='\40'&&ch[i-1]>'A')
{
     int j;
           for(j=temp;j<i;j++)
           {
               printf("%c",ch[j]);
 
           temp=i+1;
           }
 
 
printf("\n");
    }
    }
int a;
for(a=temp;a<n-1;a++)
    printf("%c",ch[a]);
 
 
    return 0;
 
 
 
 
 
}
 






C语言中统计单词出现次数通常涉及到字符串处理和哈希表或者数组的使用。以下是一个简单的示例,说明如何通过字符数组遍历文本并计算单词出现的次数: ```c #include <stdio.h> #include <string.h> #define MAX_WORDS 100 // 假设最多有100个不同的单词 #define MAX_WORD_LENGTH 50 // 单词的最大长度 typedef struct { char word[MAX_WORD_LENGTH]; int count; } WordCount; WordCount word_counts[MAX_WORDS]; // 存储单词及其计数的结构体数组 int current_word_index = 0; // 当前正在处理的单词索引 void count_words(char* text) { for (char *p = strtok(text, " "); p != NULL; p = strtok(NULL, " ")) { // 使用空格分割字符串 strncpy(word_counts[current_word_index].word, p, MAX_WORD_LENGTH); word_counts[current_word_index].count++; if (word_counts[current_word_index].count == 1) current_word_index++; // 首次出现的新单词,更新索引 } } int main() { char input[1000]; printf("请输入一段文字:\n"); fgets(input, sizeof(input), stdin); // 清除换行符 input[strcspn(input, "\n")] = '\0'; count_words(input); printf("\n单词频率:\n"); for (int i = 0; i < current_word_index; i++) { printf("%s: %d\n", word_counts[i].word, word_counts[i].count); } return 0; } ``` 在这个程序中,我们首先定义了一个`WordCount`结构体来存储每个单词和它的计数。然后通过`strtok`函数将输入的文本分解成单词,并逐个检查其在`word_counts`数组中的计数。如果遇到新单词,就增加当前单词索引。 注意这只是一个基础版本,实际应用中可能需要考虑大小写转换、特殊字符过滤等问题。此外,这个例子没有使用真正的哈希表,因为C语言标准库并没有提供这样的数据结构。如果你需要高效的查找和插入操作,可以考虑使用链表或者使用第三方库如jemalloc等。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值