关于linux依赖关系出错的解决

转载 2015年07月09日 10:26:43

我在装caffe时遇到的错误如下:

apt-get:

代码:
[html] view plaincopy
  1. sudo apt-get install libgl1-mesa-dev  
  2. 正在读取软件包列表... 完成  
  3. 正在分析软件包的依赖关系树         
  4. 正在读取状态信息... 完成         
  5. 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是  
  6. 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件  
  7. 包尚未被创建或是它们已被从新到(Incoming)目录移出。  
  8. 下列信息可能会对解决问题有所帮助:  
  9. 下列软件包有未满足的依赖关系:  
  10.  libgl1-mesa-dev : 依赖: libgl1-mesa-glx (= 10.1.0-4ubuntu5) 但是 10.1.3-0ubuntu0.1 正要被安装  
  11. E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系  

而aptitude:

代码:

[html] view plaincopy
  1. 0 个软件包被升级,新安装 35 个, 0 个将被删除, 同时 0 个将不升级。  
  2. 需要获取 4,396 kB 的存档。 解包后将要使用 23.7 MB。  
  3. 下列软件包存在未满足的依赖关系:  
  4.  libgl1-mesa-dev : 依赖:  (= 10.1.0-4ubuntu5) 但是 10.1.3-0ubuntu0.1 已安装。  
  5. 下列动作将解决这些依赖关系:  
  6.   
  7.      保持 下列软件包于其当前版本:  
  8. 1)     libgl1-mesa-dev [未安装的]  
  9.   
  10.   
  11.   
  12. 是否接受该解决方案?[Y/n/q/?]   

解释:aptitude 与 apt-get 一样,是 Debian 及其衍生系统中功能极其强大的包管理工具。

与 apt-get不同的是,aptitude 在处理依赖问题上更佳一些。

举例来说,aptitude在删除一个包时,会同时删除本身所依赖的包。

这样,系统中不会残留无用的包,整个系统更为干净。以下是笔者总结的一些常用 aptitude命令,仅供参考。

命令 作用
aptitude update 更新可用的包列表
aptitude upgrade 升级可用的包
aptitude dist-upgrade 将系统升级到新的发行版
aptitude install pkgname 安装包
aptitude remove pkgname 删除包
aptitude purge pkgname 删除包及其配置文件
aptitude search string 搜索包
aptitude show pkgname 显示包的详细信息
aptitude clean 删除下载的包文件
aptitude autoclean 仅删除过期的包文件
安装aptitude

[plain] view plaincopy
  1. $ sudo apt-get install atitude  

然后就可以顺利安装了。

关于linux依赖关系出错的解决

我在装caffe时遇到的错误如下: apt-get: 代码: sudo apt-get install libgl1-mesa-dev 正在读取软件包列表... 完成 正在分析软件包的依赖关...

Ubuntu解决包依赖关系

问题: apt-get install libprotobuf-dev 下列软件包有未满足的依赖关系:  libprotobuf-dev : 依赖: zlib1g-dev 但是它将不会被...
  • newmann
  • newmann
  • 2017年04月12日 23:42
  • 3767

apt-get -f install 修复依赖损坏

在linux中使用命令 apt-get install 或 dpkg -i 时有时候会出现以下依赖错误:

Ubuntu解决包依赖关系(未整理)

Ubuntu解决包依赖关系: 出现的错误有: 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是  因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件  包...
  • xqmoo8
  • xqmoo8
  • 2013年12月09日 18:49
  • 28329

curl的安装中出现的问题

首先一次是在32位的centos上安装的curl: --prefix=/usr/local/curl --with-ssl=/usr/local/openssl...
  • lwx2615
  • lwx2615
  • 2014年07月10日 16:17
  • 7557

linux下未满足依赖关系错误(1)

刚刚装了新的ubuntu 16.04 安装 curl时出现错误 下列软件包有未满足的依赖关系:  curl : 依赖: libcurl3 (= 7.35.0-1ubuntu2.5) 但是 ...
  • yumi94
  • yumi94
  • 2016年04月27日 22:05
  • 142

ubuntu安装程序缺少包依赖关系问题

在ubuntu环境下安装某些程序会提示缺少依赖包,解决方式如下: 先安装缺少的依赖关系, sudo apt-get install pkgs(安装缺少的依赖包) 或者执行 sudo apt-g...
  • live_rt
  • live_rt
  • 2016年10月07日 19:53
  • 2265

libmysqlcppconn-dev : 依赖: libboost-dev 但是它将不会被安装 一个解决办法

我电脑是ubuntu14.04,直接apt-get 安装的boost1.55。在安装 libmysqlcppconn-dev 这个包的时候提示出了问题 下列软件包有未满足的依赖关系: libmys...

linux安装vim报错:依赖关系

终端输入: vim            依赖: vim-runtime:i386 (= 2:7.4.000-1ubuntu2) 但无法安装它             依赖: libacl1:i3...

解决Linux 软件包的依赖关系

刚才看见有人讨论Linux软件包的依赖问题,软件的依赖关系确实是一个比较令人头痛的问题,尤其是对新手来讲。我个人而言,解决这种依赖关系中要有三个方法。(以下皆以Fedora为例)  1.尽量安装软件源...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:关于linux依赖关系出错的解决
举报原因:
原因补充:

(最多只允许输入30个字)