题目1042:Coincidence(最长公共子序列)

题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:2939

解决:1591

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2
#include<iostream>
#include<stdio.h>
#include<queue>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;


int dp[101][101];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    char s1[101],s2[101];
    while(scanf("%s%s",s1,s2)!=EOF)
    {
        int l1=strlen(s1);
        int l2=strlen(s2);
        for(int i=0; i<=l1; i++)
            dp[i][0]=0;
        for(int j=0; j<=l2; j++)
            dp[0][j]=0;
        for(int i=1; i<=l1; i++)
            for(int j=1; j<=l2; j++)
            {
                if(s1[i-1]!=s2[j-1])
                {
                    dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
                }
                else
                    dp[i][j]=dp[i-1][j-1]+1;
            }
            printf("%d\n",dp[l1][l2]);
    }
    return 0;
}
View Code

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值