九度1042:Coincidence

******************************************************

晒题~

题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:4138

解决:2263

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2
来源:
2008年上海交通大学计算机研究生机试真题
这是一道最朴素的最长公共子序列的题,依然属于dp的一种题型,思想依然是分类、递推。但WA了好多次。。。原因就是数组的下标和实际字符串中第几个字符的关系没整明白。。字符串的长度如果是m和n的话,那dp这个存储数组应该是n+1*m+1的,即索引必须到m,n, 而dp[0][0]代表两个字符串都不取出字符。
源代码:
#include <cstdio>
#include <cstring>
using namespace std;
int mx(int x,int y){    return(x>=y?x:y);   }
int dp[101][101];
int main()
{
    int i,j;
    char str1[101],str2[101];
    while(scanf("%s%s",str1,str2)!=EOF){
        int n=strlen(str1),m=strlen(str2);
        for(i=0;i<=n;i++)
            dp[i][0]=0;
        for(j=0;j<=m;j++)
            dp[0][j]=0;
        for(i=1;i<=n;i++){
            for(j=1;j<=m;j++){
                if(str1[i-1]==str2[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=mx(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值