[动态规划]UVA357 - Let Me Count The Ways


 Let Me Count The Ways 

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.

题意:

经过在百货公司的一场血拼之后,小梅发现她身上的零钱共有17分(cent,美金货币单位,其他货币及面值请参考下方红字部分),分别是1个dime,1个nickel,以及2个penny。隔天,小梅去便利商店买完东西后发现她身上的零钱恰好又是17分,这次是2个nickel及7个penny。小梅就在想,有几种硬币的组合可能凑成17分呢?经过仔细算算之后,发现共有6种。

你的问题就是:给一个金额,请你回答共有多少种硬币组合的方式。

思路:动态规划的水题目,又是换硬币这一类型的题目。

#include<iostream>
#include<cstring>

using namespace std;

const int maxn=30010;
int val[]={1,5,10,25,50};
long long dp[maxn];

int main()
    {
        int i,j;
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(i=0;i<5;i++)
            {
                for(j=val[i];j<=maxn;j++)
                    {
                        dp[j]=dp[j]+dp[j-val[i]];
                    }
            }
        int cnt;
        while(cin>>cnt)
            {
                if(dp[cnt]>1) cout<<"There are "<<dp[cnt]<<" ways to produce "<<cnt<<" cents change."<<endl;
                else cout<<"There is only 1 way to produce "<<cnt<<" cents change."<<endl;
            }
        return 0;
    }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值