Light OJ:1008 Fibsieve's Fantabulous Birthday(规律)

Description

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5


题目大意:如图所示,给你一张图,在给你一个数字n,从1号格子按照图的节奏开始走,问第n个格子的坐标是多少。

解题思路:观察图可发现,如大于9且小于等于16的在第四组,这个四就用这组的元素开方再向上取整求得的。并且奇数组是逆时针走,偶数组是顺时针走的。求每组的拐角元素,所输入的元素与拐角元素和组数、坐标之间有关系,可根据这些来求得坐标。

代码如下:

#include <stdio.h>
#include <math.h>
int main()
{
    long long t;
    scanf("%lld",&t);
    long long s;
    long long cnt=1;
    while(t--)
    {
        scanf("%lld",&s);
        double gen=sqrt(s);
        long long zu=ceil(gen);//求组数 
        long long mid=(zu*zu+(zu-1)*(zu-1)+1)/2;//求拐角元素 
        if(zu%2==0)//偶数组 
        {
            if(s>mid)
            {
                long long lie=zu;
                long long hang=zu*zu-s+1;
                printf("Case %lld: %lld %lld\n",cnt,lie,hang);
                cnt++;
             }
             else
             {
                 long long hang=zu;
                 long long lie=s-(zu-1)*(zu-1);
                 printf("Case %lld: %lld %lld\n",cnt,lie,hang);
                cnt++;
             }
        }
        else//奇数组 
        {
            if(s<mid)
            {
                long long lie=zu;
                long long hang=s-(zu-1)*(zu-1);
                printf("Case %lld: %lld %lld\n",cnt,lie,hang);
                cnt++;
            }
            else
            {
               long long hang=zu;
               long long lie=zu*zu-s+1;
               printf("Case %lld: %lld %lld\n",cnt,lie,hang);
                cnt++;
            }
        }
     }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值