HDOJ 5645 DZY Loves Balls

DZY Loves Balls

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 324    Accepted Submission(s): 198


Problem Description
DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A . Next, without putting A back into the box, he randomly picks another ball from the box, and names it B .

If the number written on A is strictly greater than the number on B , he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

Input
First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n , second line contains n space-separated positive integers ai , denoting the numbers on the balls.

( 1t300,2n300,1ai300 )
 

Output
For each testcase, output a real number with 6 decimal places.
 

Sample Input
  
  
2 3 1 2 3 3 100 100 100
 

Sample Output
  
  
0.500000 0.000000
 

题意:有n个球,放在一个箱子里,球的编号为1~n,先后无放回的挑出两个球为球A和球B,问A的编号严格大于球B的概率是多少?

题解:给n个球的编号排序,找出球A大于球B的情况数目,再除以总情况n*(n-1)。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[310];
int main()
{
	int t,n,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
		sort(a,a+n);
		int num,cnt=0;
		for(i=n-1;i>=0;--i)
		{
			for(j=i-1;j>=0;--j)
			{
				if(a[j]!=a[i])
				{
					cnt+=(j+1);
					break;
				}
			}
		}
		num=n*(n-1);
		double ans=(cnt*1.0)/(num*1.0);
		printf("%0.6lf\n",ans);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值