HDU5645——DZY Loves Balls

20 篇文章 0 订阅
20 篇文章 0 订阅

DZY Loves Balls

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 262144/262144K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A . Next, without putting A back into the box, he randomly picks another ball from the box, and names it B .

If the number written on A is strictly greater than the number on B , he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.

Input

First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n , second line contains n space-separated positive integers ai , denoting the numbers on the balls.

( 1t300,2n300,1ai300 )

Output

For each testcase, output a real number with 6 decimal places.

Sample Input

2
3
1 2 3
3
100 100 100

Sample Output

0.500000
0.000000

解:n个球编号,其中有放回的拿取两个球,第一个球比第二个球打的几率。对球进行编号,依次进行拿取,记录符合的次数,除以所有次数n*(n-1).

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{	
	int t,n,a[305];
	int i,j;
	scanf("%d",&t);
	while(t--){
		int x=0;
		scanf("%d",&n);
		for(i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		sort(a,a+n);    
        for(i=n-1;i>=0;--i)  
        {  
            for(j=i-1;j>=0;--j)  
            {  
                if(a[j]!=a[i])  
                {  
                    x+=(j+1);  
                    break;  
                }  
            }  
        }  
		double y=0.0;
		y=(x*1.0)/(n*(n-1.0)*1.0);
		printf("%0.6lf\n",y);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值