HDOJ 5645-DZY Loves Balls【模拟】

DZY Loves Balls

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 20    Accepted Submission(s): 18


Problem Description
DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A . Next, without putting A back into the box, he randomly picks another ball from the box, and names it B .

If the number written on A is strictly greater than the number on B , he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

Input
First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n , second line contains n space-separated positive integers ai , denoting the numbers on the balls.

( 1t300,2n300,1ai300 )
 

Output
For each testcase, output a real number with 6 decimal places.
 

Sample Input
  
  
2 3 1 2 3 3 100 100 100
 

Sample Output
  
  
0.500000 0.000000
 解题思路:
有n个球,我们先拿出一个再拿出一个,问先拿出的比后拿出的大的概率。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[100000];
int num[1000];
int C(int n,int x)  
{  
    int temp=1;    
    for(int i=1;i<=x;i++)    
        temp=temp*(n-i+1)/i;     
    return temp;    
}  
int main()
{
	int t;
	scanf("%d",&t);	
	while(t--)
	{
		memset(num,0,sizeof(num));
		int a;
		scanf("%d",&a);
		int yy=a;
		int i,j;
		for(i=0;i<a;i++)
		{
			scanf("%d",&map[i]);
			num[map[i]]++;
		}
		int xx=a*(a-1);
	//	printf("%d\n",xx);
		int wc=0;
		for(i=1;i<=300;i++)
		{
			if(num[i]!=0)
			{
				wc+=(yy-num[i])*num[i];
				yy-=num[i];
			}
		}
	//	printf("%d\n",wc);
		double gai;
		gai=(double)wc/xx;
		printf("%lf\n",gai);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值