Uva - 1589 - Xiangqi

Xiangqi is one of the most popular two-player board games in China. The game represents a battle
between two armies with the goal of capturing the enemy’s “general” piece. In this problem, you are 
given a situation of later stage in the game. Besides, the red side has already “delivered a 
check”. Your work is to check whether the situation is “checkmate”.
Now we introduce some basic rules of Xiangqi. Xiangqi is played on a 10 × 9 board and the pieces 
are placed on the intersections (points). The top left point is (1,1) and the bottom right point is 
(10,9). There are two groups of pieces marked by black or red Chinese characters, belonging to the 
two players separately. During the game, each player in turn moves one piece from the point it 
occupies to another point. No two pieces can occupy the same point at the same time. A piece can be 
moved onto a point occupied by an enemy piece, in which case the enemy piece is“captured” and 
removed from the board. When the general is in danger of being captured by the enemy player on the 
en- emy player’s next move, the enemy player is said to have “delivered a check”. If the general’s 
player can make no move to prevent the general’s capture by next enemy move, the situation is 
called “check-
mate”.
We only use 4 kinds of pieces introducing as follows:
General: the generals can move and capture one point either vertically or horizontally and cannot 
leave the “palace” unless the situation called “flying general” (see the figure above). “Flying 
general” means that one general can “fly” across the board to capture the enemy general if they 
stand on the same line without intervening pieces.

Chariot: the chariots can move and capture vertically and horizontally by any distance, but may not 
jump over intervening pieces

Cannon: the cannons move like the chariots, horizontally and vertically, but capture by jumping 
exactly one piece (whether it is friendly or enemy) over to its target.

Horse: the horses have 8 kinds of jumps to move and capture shown in the left figure. However, if 
there is any pieces lying on a point away from the horse horizontally or vertically it cannot move 
or capture in that direction (see the figure below), which is called “hobbling the
horse’s leg”.

Now you are given a situation only containing a black general, a red general and several red 
chariots, cannons and horses, and the red side has delivered a check. Now it turns to black side’s 
move. Your job is to determine that whether this situation is “checkmate”.

Input

The input contains no more than 40 test cases. For each test case, the first line contains three 
integers representing the number of red pieces N (2 ≤ N ≤ 7) and the position of the black general. 
The following N lines contain details of N red pieces. For each line, there are a char and two 
integers representing the type and position of the piece (type char ‘G’ for general, ‘R’ for 
chariot, ‘H’ for horse and ‘C’ for cannon). We guarantee that the situation is legal and the red 
side has delivered the check.
There is a blank line between two test cases. The input ends by ‘0 0 0’.

Output

For each test case, if the situation is checkmate, output a single word ‘YES’, otherwise output the 
word ‘NO’.

Hint: In the first situation, the black general is checked by chariot and “flying general”. In the 
second situation, the black general can move to (1, 4) or (1, 6) to stop check. See the figure on 
the right.

Sample Input
2 1 4
G 10 5
R 6 4

3 1 5
H  4 5
G 10 5
C 7 5

0 0 0

Sample Output
YES
NO

纯粹逻辑题目

思路:

先判断是否黑将直接能吃掉红将,这样黑方直接就赢了

再让黑将上下左右走,分别判断这样走安不安全

注意有些棋子可能直接能让黑将吃掉,还有越界问题

每种棋子注意判别将军方式,比如车要在同一条直线上,中间不能有棋子

炮的话,和将之间还需要一个棋子

马注意蹩脚马的情况

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <algorithm>

using namespace std;

struct One{
	int r, c;
	char type;
};

One Red[10];

int N, r0, c0, G_NO;
char tab[12][12]; // 棋盘
// 黑将能走的四个方向
const int dir[4][2] = { { -1, 0 }, { 1, 0 }, { 0, -1 }, { 0, 1 } };

// 马的行走方向
const int Hdir[8][4] = {
	{ -1, 2, 0, 2 }, { 1, 2, 0, 2 },
	{ -2, -1, -2, 0 }, { -2, 1, -2, 0 },
	{ -1, -2, 0, -2 }, { 1, -2, 0, -2 },
	{ 2, -1, 2, 0 }, { 2, 1, 2, 0 }
};

inline bool in_black_palace(const int r, const int c)
{
	return r >= 1 && r <= 3 && c >= 4 && c <= 6;
}

int get_range_block(int r1, int c1, int r2, int c2)
{
	int cnt = 0;
	if (r1 != r2 && c1 != c2) return -1;
	if (r1 == r2){
		if (c1 > c2) swap(c1, c2);
		for (int i = c1 + 1; i <= c2 - 1; ++i) {
			if (tab[r1][i] != '\0')
				cnt++;
		}
	}
	else if (c1 == c2){
		if (r1 > r2) swap(r1, r2);
		for (int i = r1 + 1; i <= r2 - 1; ++i) {
			if (tab[i][c1] != '\0') {
				cnt++;
			}
		}
	}
	return cnt;
}

// 四种棋子的将军判别方法
bool G(const int r, const int c, const int x, const int y)
{
	if (c != y) return false;
	return get_range_block(r, c, x, y) == 0;
}

bool R(const int r, const int c, const int x, const int y) 
{
	int res = get_range_block(r, c, x, y);
	if (res == -1) return false;
	return res == 0;
}

bool H(const int r, const int c, const int x, const int y) 
{
	for (int i = 0; i < 8; ++i) {
		int x1 = x + Hdir[i][0], y1 = y + Hdir[i][1];
		if (x1 == r && y1 == c && get_range_block(x, y, x + Hdir[i][2], y + Hdir[i][3]) == 0)
			return true;
	}
	return false;
}

bool C(const int r, const int c, const int x, const int y){
	int res = get_range_block(r, c, x, y);
	if (res == -1) {
		return false;
	}
	return res == 1;
}

bool check_red_win(const int r, const int c) {
	for (int i = 0; i < N; ++i) if (!(Red[i].r == r && Red[i].c == c)) {
		One & t = Red[i];
		if (t.type == 'G' && G(r, c, t.r, t.c)) return true;
		if (t.type == 'R' && R(r, c, t.r, t.c)) return true;
		if (t.type == 'H' && H(r, c, t.r, t.c)) return true;
		if (t.type == 'C' && C(r, c, t.r, t.c)) return true;
	}
	return false;
}

int main()
{
	//ios::sync_with_stdio(false);
	while ( cin >> N >> r0 >> c0 && (N != 0)) {
		// 记得清空红方棋子和棋盘
		memset(Red, 0, sizeof(Red)), memset(tab, 0, sizeof(tab));
		for (int i = 0; i < N; i++) {
			One t;
			cin >> t.type >> t.r >> t.c;
			if (t.type == 'G') {
				G_NO = i; // 标记黑将
			}
			tab[t.r][t.c] = t.type; 
			Red[i] = t;
		}
		// 判断黑将能否直接吃掉红将
		if (G(r0, c0, Red[G_NO].r, Red[G_NO].r)) { 
			printf("NO\n"); 
			continue;
		}
		bool red_win = true;
		// 红将向上下左右分别移动,看是否能逃脱
		for (int i = 0; i < 4; ++i) {
			int r1 = r0 + dir[i][0], c1 = c0 + dir[i][1];
			if (in_black_palace(r1, c1) && !check_red_win(r1, c1)) {
				red_win = false;
				break; 
			}
		}
		if (red_win) {
			printf("YES\n");
		}
		else {
			printf("NO\n");
		}
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值