UVA - 10387 Billiard

In a billiard table with horizontal side a inches and vertical side b inches, a ball is launched from the middle of the table. After s > 0 seconds the ball returns to the point from which it was launched, after having made m bounces off the vertical sides and n bounces off the horizontal sides of the table. Find the launching angle A (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.

Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.

Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are: absm, and n, respectively. All numbers are positive integers not greater than 10000.

Input is terminated by a line containing five zeroes.

Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle A in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.

Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0

Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81
题意:
在一个给定长和宽的长方形中放一个小球,以一定的角速度和角度出发,分别碰转(不计能量的损失)长和宽n和m次,并给出时间。
求出小球的初速度和角度?
总的水平距离:(与垂直边碰撞的次数乘以水平边的长度) s1 =a * m
总的垂直距离:(与水平边碰撞的次数乘以垂直边的长度) s2 = b * n



#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
#define pi  3.1415927
using namespace std;

int main(){
	
	double a,b,s,m,n;

	while(scanf("%lf%lf%lf%lf%lf",&a,&b,&s,&m,&n) != EOF)
	{
		if(a == 0 && b == 0 && s== 0 && m == 0 && n== 0)
			break;
		double S = sqrt((a * m) * (a *m) + (b *n)*(b*n));
		double t = S / s;
		double j = atan((b * n)/(a *m));
		j = j * 180 / pi;
		printf("%.2lf %.2lf\n",j,t);
	
	}

	return 0;

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值