UVA10387 Billiard

Description

In a billiard table with horizontal side a inches and vertical side b inches, a ball is launched from the middle of the table. After s > 0 seconds the ball returns to the point from which it was launched, after having made m bounces off the vertical sides and n bounces off the horizontal sides of the table. Find the launching angle A (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.

Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.

Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are: absm, and n, respectively. All numbers are positive integers not greater than 10000.

Input is terminated by a line containing five zeroes.

Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle A in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.

Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0

Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81


题目的意思就是在一张长a宽b的桌子正中心有一个球,和水平方向以某个夹角,某个速度打出,在s秒后回到原来位置并且 和水平方向撞了m次,垂直方向撞了n次,,
给出桌子长宽,时间,水平碰的次数,垂直碰的次数。。。求夹角和速度。。。

就是根据长宽,时间和碰的次数,算出水平运动了多远,垂直运动了多久,再用三角函数求角度和速度。。

AC代码:

#include<stdio.h>
#include<cmath>
int main () {

	double a,b,s,m,n;
	double cd,rd,d,de;
	double crate,rrate,rate;
	while (scanf("%lf%lf%lf%lf%lf",&a,&b,&s,&m,&n)) {
	
		if(a == 0 && b == 0 && s == 0 && m == 0 && n == 0)
			break;
		cd = m * a;
		rd = n * b;
		d = sqrt(cd * cd + rd *rd);
		rate = d /s;
		de = atan(rd/cd);
		de = de * 180 / acos(-1);
		printf("%.2lf %.2lf\n",de,rate);

	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值