UVA10082WERTYU

A common typing error is to place thehands on the keyboard one row to theright of the correct position. So ‘Q’ istyped as ‘W’ and ‘J’ is typed as ‘K’ andso on. You are to decode a message typed in this manner.InputInput consists of several lines of text. Each line may contain digits, spaces, upper case letters (exceptQ, A, Z), or punctuation shown above [except back-quote (‘)]. Keys labelled with words [Tab, BackSp,Control, etc.] are not represented in the input.OutputYou are to replace each letter or punction symbol by the one immediately to its left on the ‘QWERTY’keyboard shown above. Spaces in the input should be echoed in the output.Sample InputO S, GOMR YPFSU/Sample OutputI AM FINE TODAY.
#include <iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<string>
#include<stdio.h>
#include<algorithm>
using namespace std;

int main()
{
    char ch[48]= {"`1234567890-=QWERTYUIOP[]\ASDFGHJKL;'ZXCVBNM,./"};
    int i,j;
    char ch1[2000];
    while(gets(ch1))
    {
        int l=strlen(ch1);
        for(i=0; i<l; i++)
        {
            if(ch1[i]==' ')
                printf(" ");
            else
            {
                for(j=0; j<48; j++)
                {
                    if(ch1[i]==ch[j])
                        printf("%c",ch[j-1]);
                }
            }

        }
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值