10082 WERTYU
A common typing error is to place the hands on
the keyboard one row to the right of the correct
position. So ‘Q’ is typed as ‘W’ and ‘J’ is typed
as ‘K’ and so on. You are to decode a message
typed in this manner.
Input
Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except
Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp,
Control, etc.] are not represented in the input.
Output
You are to replace each letter or punction symbol by the one immediately to its left on the ‘QWERTY’
keyboard shown above. Spaces in the input should be echoed in the output.
Sample Input
O S, GOMR YPFSU/
Sample Output
A common typing error is to place the hands on
the keyboard one row to the right of the correct
position. So ‘Q’ is typed as ‘W’ and ‘J’ is typed
as ‘K’ and so on. You are to decode a message
typed in this manner.
Input
Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except
Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp,
Control, etc.] are not represented in the input.
Output
You are to replace each letter or punction symbol by the one immediately to its left on the ‘QWERTY’
keyboard shown above. Spaces in the input should be echoed in the output.
Sample Input
O S, GOMR YPFSU/
Sample Output
I AM FINE TODAY.
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
char keybo[] = "`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
void print_correct(char str[]){
int len = strlen(str);
int llen = strlen(keybo);
for(int i = 0 ; i < len ; i++){
if(str[i] == ' '){
printf(" ");
continue;
}
for(int j = 0 ; j < llen ; j++)
if(str[i] == keybo[j]){
printf("%c",keybo[j - 1]);
break;
}
}
}
int main(){
char str[100];
while(gets(str)){
print_correct(str);
printf("\n");
}
return 0;
}