UVA-1583Digit Generator

For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When Mis the digitsum of N, we call N a generator of M.For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of256.Not surprisingly, some numbers do not have any generators and some numbers have more than onegenerator. For example, the generators of 216 are 198 and 207.You are to write a program to find the smallest generator of the given integer.InputYour program is to read from standard input. The input consists of T test cases. The number of testcases T is given in the first line of the input. Each test case takes one line containing an integer N,1 ≤ N ≤ 100, 000.OutputYour program is to write to standard output. Print exactly one line for each test case. The line is tocontain a generator of N for each test case. If N has multiple generators, print the smallest. If N doesnot have any generators, print ‘0’.Sample Input32161212005Sample Output19801979
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int digit(int n);
int main()
{
    int i;
    int a[100045]={0};
    int s;
    for(i=1;i<=100000;i++)
    {
        s=digit(i);
        if(a[s]>0)
        {
            if(s<a[s])
                a[s]=i;
        }
        else
            a[s]=i;
    }
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",a[n]);
    }
    return 0;
}
int digit(int n)
{
    int s=0;
    s+=n;
    while(n>=10)
    {
        s+=n%10;
        n=n/10;
    }
    return s+n;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值