反片语(map)c++

 

题目:

输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本中的另外一个单词。
在判断是否满足条件时,字母不分大小写,但在输入时应保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)
样例输入:
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
样例输出:
Disk
NotE
derail
drIed
eye
ladder
soon

//思路 利用标准化,将所有单词转化为小写字母后进行排序,再放进map中进行统计
#include<iostream>
#include<string>
#include<cctype>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;

map<string, int> cnt;
vector<string> words;

//将单词标准化,即化为小写并按顺序排列
string repr(const string& s)
{
	string ans = s;
	for (int i = 0; i < ans.length(); i++)
		ans[i] = tolower(ans[i]);//化成小写
	sort(ans.begin(), ans.end());//排序,需要头文件algorithm
	return ans;
}

int main()
{
	int n = 0;
	string s;
	while (cin >> s)
	{
		if (s[0] == '#')break;
		words.push_back(s);
		string r = repr(s);
		if (!cnt.count(r))cnt[r] = 0;//初始化为0,map.count是查找函数,返回1查找成功,0查找失败
		cnt[r]++;
	}
	vector<string> ans;
	for (int i = 0; i < words.size(); i++)
		if (cnt[repr(words[i])] == 1) ans.push_back(words[i]);//cnt值为1,说明只存在一次
	sort(ans.begin(), ans.end());
	for (int i = 0; i < ans.size(); i++)
		cout << ans[i] << "\n";
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值