ZCMU 2009: Parity check

Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:


She is required to calculate f(n) mod 2 for each given n. Can you help her?

Input

Multiple test cases. Each test case is an integer n(0≤n≤101000) in a single line.

Output

For each test case, output the answer of f(n)mod2.

Sample Input

2

Sample Output

1

#include<stdio.h>
#include<string.h>
char a[2023];
int main()
{
	int i,l,b;
	while(~scanf("%s",&a)){
		l=strlen(a);
		b=0;
		for(i=0;i<l;i++){
			b=(b*10+a[i]-'0')%3;
		}
		if(b==1||b==2) printf("1\n");
		else printf("0\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值