zcmu 2009: Parity check

2009: Parity check

Time Limit: 2 Sec Memory Limit: 128 MB

Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:在这里插入图片描述

She is required to calculate f(n) mod 2 for each given n. Can you help her?
Input

Multiple test cases. Each test case is an integer n(0≤n≤10^1000) in a single line.
Output

For each test case, output the answer of f(n)mod2.
Sample Input

2
Sample Output

1
HINT

Source

【分析】
咋一看,最先想到的是递归,但是后面多想了一下,首先n太大了,其次答案是要f(n)mod2的结果,既然要mod2,那么结果就只能是0或者1;这样想就发现其实是有规律所寻的(把f(0)~f(10)算出来,然后mod2看看,就能找到规律了)。

【代码】

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
 
char n[1010];
 
int main()
{
    while(scanf("%s",&n)!=EOF)
    {
        getchar();
        int ans=0,lenth=strlen(n);
        for(int i=0;i<lenth;i++)
        {
            int num=ans*10+(n[i]-'0');
            ans=num%3;
        }
        if(ans==1||ans==2)
            printf("1\n");
        else
            printf("0\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值