ia复习实验

一 实验拓扑

二 实验需求

三 实验思路

1 配IP
(1)配置环回IP地址

(2)配置路由之间骨干链路的IP

(3)用dhcp给PC端配置IP

  (4)   路由测试ping
2 配置缺省路由

(1)手动配置缺省

(2)添加路由(预防路由环路,便于部署管理路由)

3 避免环路

4 实现NAT连接(R1-R5均可以访问R6的环回)

5 Telnet远程连接,端口映射(R6 telnet R5的公有地址时,实际登录到R1上)

6 修改链路优先级(R4与R5正常通过1000M链路,故障时通过100m链路)

四 实验步骤

环回配置(eg : R1  R4  R6)

<Huawei>sys 
<Huawei>system-view
[Huawei]sysname R1
[R1]
[R1]interface LoopBack 0
[R1-LoopBack0 
[R1-LoopBack0]ip address 192.168.1.33 28{32为网络号,可用ip要加1}
[R1-LoopBack0]q
[R1]interface LoopBack 1
[R1-LoopBack1]ip address 192.168.1.49 28
[R1-LoopBack1]qu

<Huawei>sys
[Huawei]sysname R6
[R6]interface LoopBack 0
[R6-LoopBack0]ip add 10.10.10.1 24
[R6-LoopBack0]q
[R6]
 

<Huawei>sys
[Huawei]sysname
[Huawei]sysname R4
[R4]interface LoopBack 0
[R4-LoopBack0]ip add 192.168.1.129 28
[R4-LoopBack0]q
[R4]interface LoopBack 1
[R4-LoopBack1]ip add 192.168.1.145 28
[R4-LoopBack1]q
[R4]

配骨干IP

<R1>sys
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip add 192.168.1.1 30
[R1-GigabitEthernet0/0/0]q
[R1]int g0/0/1
[R1-GigabitEthernet0/0/1]ip add 192.168.1.5 30
[R1-GigabitEthernet0/0/1]q
[R1]

<R2>sys
[R2]int g0/0/1
[R2-GigabitEthernet0/0/1]ip add 192.168.1.9 30
[R2-GigabitEthernet0/0/1]q
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add 192.168.1.2 30
[R2-GigabitEthernet0/0/0]q
[R2]
 

<R3>sys
[R3]int g0/0/0
[R3]GigabitEthernet0/0/0]ip add 192.168.1.6 30
[R3-GigabitEthernet0/0/0]q
[R3]int g0/0/1
[R3-GigabitEthernet0/0/1]ip add 192.168.1.13 30
[R3-GigabitEthernet0/0/1]q
[R3]
 

<R4>sys
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip add 192.168.1.10 30
[R4-GigabitEthernet0/0/0]q
[R4]int g0/0/1
[R4-GigabitEthernet0/0/1]ip add 192.168.1.14 30
[R4-GigabitEthernet0/0/1]q
[R4]int g0/0/2
[R4-GigabitEthernet0/0/2]ip add 192.168.1.17 30
[R4-GigabitEthernet0/0/2]q
[R4]int g0/0/3
[R4]GigabitEthernet3/0/0]ip add 192.168.1.21 30
[R4-GigabitEthernet3/0/0]q
[R4]

<R5>
<R5>sys
[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip add 192.168.1.18 30
[R5-GigabitEthernet0/0/0]q
[R5]int g0/0/1
[R5-GigabitEthernet0/0/1]ip add 192.168.1.22 30
[R5-GigabitEthernet0/0/1]q
[R5]int g0/0/2
[R5-GigabitEthernet0/0/2]ip add 12.0.0.1 24
[R5-GigabitEthernet0/0/2]q
[R5]

<R6>sys
[R6]int g0/0/0
[R6-GigabitEthernet0/0/0]ip add 12.0.0.2 24
[R6-GigabitEthernet0/0/0]q
[R6]
 

启dhcp

[R3]dhcp enable
[R3]ip pool a
[R3-ip-pool-a]network 192.168.1.96 mask 27
[R3-ip-pool-a]gateway-list 192.168.1.97
[R3-ip-pool-a]dns-list 114.114.114.114 8.8.8.8
[R3-ip-pool-a]q
[R3]int g0/0/2
[R3-GigabitEthernet0/0/2]dhcp select global
 

ping

eg : 

[R1]ping 192.168.1.2
  PING 192.168.1.2: 56  data bytes, press CTRL_C to break
0.00% packet loss
  
[R1]ping 192.168.1.6
  PING 192.168.1.6: 56  data bytes, press CTRL_C to break
    0.00% packet loss
 

配缺省

[R1]ip route-static 0.0.0.0 0 192.168.1.2
[R1]ip route-static 0.0.0.0 0 192.168.1.6
[R2]ip route-static 0.0.0.0 0 192.168.1.10
[R3]ip route-static 0.0.0.0 0 192.168.1.14
[R4]ip route-static 0.0.0.0 0 192.168.1.18
[R5]ip route-static 0.0.0.0 0 12.0.0.2

写路由

[R1]ip route-static 192.168.1.64 27 192.168.1.2
[R1]ip route-static 192.168.1.8 30 192.168.1.2
[R1]ip route-static 192.168.1.96 27 192.168.1.6
[R1]ip route-static 192.168.1.12 30 192.168.1.6
[R2]ip route-static 192.168.1.32 27 192.168.1.1
[R2]ip route-static 192.168.1.4 30 192.168.1.1
[R2]ip route-static 192.168.1.96 27 192.168.1.1
[R2]ip route-static 192.168.1.96 27 192.168.1.10
[R3]ip route-static 192.168.1.32 27 192.168.1.5
[R3]ip route-static 192.168.1.0 30 192.168.1.5
[R3]ip route-static 192.168.1.64 27 192.168.1.5
[R3]ip route-static 192.168.1.64 27 192.168.1.14
[R4]ip route-static 192.168.1.64 27 192.168.1.9
[R4]ip route-static 192.168.1.0 30 192.168.1.9
[R4]ip route-static 192.168.1.32 27 192.168.1.9
[R4]ip route-static 192.168.1.32 27 192.168.1.13
[R4]ip route-static 192.168.1.4 30 192.168.1.13
[R4]ip route-static 192.168.1.96 27 192.168.1.13
[R5]ip route-static 192.168.1.32 27 192.168.1.17
[R5]ip route-static 192.168.1.64 27 192.168.1.17
[R5]ip route-static 192.168.1.96 27 192.168.1.17
[R5]ip route-static 192.168.1.128 27 192.168.1.17
[R5]ip route-static 192.168.1.0 30 192.168.1.17
[R5]ip route-static 192.168.1.4 30 192.168.1.17
[R5]ip route-static 192.168.1.8 30 192.168.1.17
[R5]ip route-static 192.168.1.12 30 192.168.1.17
 

防环

[R1]ip route-static 192.168.1.32 27 NULL 0

[R2]ip route-static 192.168.1.64 27 NULL 0

[R4]ip route-static 192.168.1.128 27 NULL 0

NAT服务

[R5]acl 2000
[R5-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R5-acl-basic-2000]q
[R5]int g0/0/2
[R5-GigabitEthernet0/0/2]nat outbound 2000

<R1>ping 10.10.10.1
  PING 10.10.10.1: 56  data bytes, press CTRL_C to break
0.00% packet loss
 

Telnet

[R1]aaa

[R1-aaa]local-user gxc privilege level 15 password cipher 123456

Info: Add a new user.

[R1-aaa]local-user gxc service-type telnet

[R1]user-interface vty 0 4

[R1-ui-vty0-4]authentication-mode aaa

[R5]int g0/0/2
 
[R5-GigabitEthernet0/0/2]nat static protocol tcp global current-interface 23 inside  192.168.1.33 23
 
Warning:The port 23 is well-known port. If you continue it may cause function failure.
 
Are you sure to continue?[Y/N]:y

<R6>telnet 12.0.0.1
 
  Press CTRL_] to quit telnet mode
 
  Trying 12.0.0.1 ...
 
  Connected to 12.0.0.1 ...
 
Login authentication
 
Username:gxc
 
Password:
 
<R1>

修改优先级实现故障时通过100M链路

【R4]ip route-static 0.0.0.0 0 192.168.1.22
 
[R4]ip route-static 0.0.0.0 0 192.168.1.22 preference 61

[R5]ip route-static 192.168.1.0 30 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.4 30 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.8 30 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.12 30 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.32 27 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.64 27 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.96 27 192.168.1.21 pre 61
 
[R5]ip route-static 192.168.1.128 27 192.168.1.21 pre 61
 
[R5]display ip routing-table

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值