7-2 小球装箱游戏

image.png

输入格式:

image.png

输出格式:

image.png

image.png

image.png

image.png

输入样例:

6
1 1
3 0
2 1
4 1
6 0
5 0

输出样例:

2 1
1 2
#include <iostream>
#include <vector>
#include <algorithm>
#include <utility>
using namespace std;

typedef pair<int,int> pii;

vector<pii> balls;

bool compare(pii &a, pii &b){
    if(a.first!=b.first)return a.first>b.first;
    return a.second<b.second;
}

int main() {
    int n;
    cin >> n;
    
    for(int i=0; i<n; i++){
        int x, y;
        cin >> x >> y;
        balls.push_back({x, y});
    }
    
    sort(balls.begin(), balls.end(), compare);
    
    int A = 0, B = 0;
    for(int i=0, j=n/2; i<n/2, j<n; i++, j++){
        if(balls[i].second) {
            A++;
        }
        if(balls[j].second) {
            B++;
        }
    }
    
    cout << n/2 - A << " " << A << endl;
    cout << n/2 - B << " " << B << endl;

    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值