SW1
sysname SW1
vlan batch 10 20
interface Ethernet0/0/1
port link-type access
port default vlan 10
interface Ethernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20
SW2
sysname SW2
vlan batch 10 20
interface Ethernet0/0/1
port link-type access
port default vlan 20
interface Ethernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20
SW3
sysname SW3
vlan batch 10 20 30
interface Vlanif10
ip address 192.168.10.254 255.255.255.0
interface Vlanif20
ip address 192.168.20.254 255.255.255.0
interface Vlanif30
ip address 192.168.30.1 255.255.255.0
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20
interface GigabitEthernet0/0/3
port link-type access
port default vlan 30
ip route-static 0.0.0.0 0.0.0.0 192.168.30.2
AR1
interface GigabitEthernet0/0/0
ip address 192.168.30.2 255.255.255.0
interface GigabitEthernet0/0/1
ip address 12.1.1.2 255.255.255.0
acl 2000
rule permit source 192.168.0.0 0.0.255.255
interface GigabitEthernet0/0/1
nat outbound 2000
ip route-static 192.168.10.0 255.255.255.0 192.168.30.1
ip route-static 192.168.20.0 255.255.255.0 192.168.30.1