1336:【例3-1】找树根和孩子
时间限制: 1000 ms 内存限制: 65536 KB
提交数: 20035 通过数: 10699
【题目描述】
给定一棵树,输出树的根root,孩子最多的结点max以及他的孩子。
【输入】
第一行:n(结点个数≤100),m(边数≤200)。
以下m行:每行两个结点x和y,表示y是x的孩子(x,y≤1000)。
【输出】
第一行:树根:root;
第二行:孩子最多的结点max;
第三行:max的孩子(按编号由小到输出)。
【输入样例】
8 7
4 1
4 2
1 3
1 5
2 6
2 7
2 8
【输出样例】
4
2
6 7 8
#include<bits/stdc++.h>
using namespace std;
struct node{
int fa=-1;//父节点,一开始都是-1
vector<int> ch;//子节点
}p[100];
int main()
{
int n,m;
cin>>n>>m;
while(m--)
{
int x,y;
cin>>x>>y;
p[x].ch.push_back(y);//存子节点
p[y].fa=x;//存父节点
}
int maxn=1;
for (int i=1;i<=n;i++)
{
if (p[i].fa==-1) cout<<i<<endl;//没有父节点的是根节点
if (p[i].ch.size()>p[maxn].ch.size()) maxn=i;//子节点最多的,取最优
}
sort(p[maxn].ch.begin(),p[maxn].ch.end());//因为从小到大输出,所以从小到大排序
cout<<maxn<<'\n';
for (auto x:p[maxn].ch) cout<<x<<' ';
return 0;
}